Как не выводить шапку таблицы?

Отзывов (3)FavoriteLoadingВ закладки

Как не выводить шапку таблицы?

Т. е. при автоматически генерируемом макете выводить только данные и итоги без заголовков колонок?

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

3 Коммент.

  1. Пока нашел топорный, но работающий способ.
    При автогенерации макета, получается на самом деле несколько макетов.
    Методом тыка и перебора можно определить какой за отображение чего отвечает и устранить ненужный элемент. Например как в коде

    Пока Истина Цикл
    ЭлементРезультата = ПроцессорКомпоновкиДанных.Следующий();
    Если ЭлементРезультата = Неопределено Тогда
    Прервать;
    КонецЕсли;

    Если “” + ЭлементРезультата.Макет = “Макет8” Или “” + ЭлементРезультата.Макет = “Макет9” Тогда
    Продолжить;
    КонецЕсли;

    ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
    КонецЦикла;
    ПроцессорВывода.ЗакончитьВывод();

    Может все таки кто-то знает способ более правильный???

    • Я другой придумал. Немного получше конечно, но тоже кривоватый :)
      Делаем макет заголовка группиррвки, а потом делать строку в макете минимальной

  2. Решение уже писалось здесь: http://sysadmins.ru/topic320640.html

    повторюсь:
    В общем, это делается так:
    1. В той группировке, где нужно убрать заголовки полей(шапку) – переименовываем поля(правой кнопкой по полю – переименовать, Автополе – нельзя переименовать)
    2. Для этой группировки делаем макет оформления – без оформления. То есть идем на вкладку другие настройки и там задаем макет оформления

Оставить комментарий

RSSКомментарии в RSS

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.