Программный вывод СКД с собственным макетом, пустые строки???

Отзывов (14)FavoriteLoadingВ закладки

Вывожу в ТД отчёт, всё хорошо, все данные вывелись, но почему пустые строки после шапки и перед итогом, макет рисовал сам, области выделены верно???

 

Пример:

В СКД нарисовал макет (рис 1) и привязал его к данным (рис 2), результат (рис 3).

Код вывода:

&НаКлиенте
Процедура Сформировать(Команда)
	СКД = Отчеты.ВедомостьЗамераОстатков.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");	
	Настройки = СКД.НастройкиПоУмолчанию;	
	Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных;
	
	МакетКомпоновки = Новый КомпоновщикМакетаКомпоновкиДанных;
	Макет = МакетКомпоновки.Выполнить(СКД,Настройки,Расшифровка);
	
	ПроцессорКомпоновки = новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(Макет);
	
	ПроцессорВывода = новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	
	ТД.Очистить();
	ТД.АвтоМасштаб = Истина;
	ТД.НижнийКолонтитул.Выводить = Истина;
	ТД.НижнийКолонтитул.ТекстСправа = "Страница [&НомерСтраницы] из [&СтраницВсего]";
	
	ПроцессорВывода.УстановитьДокумент(ТД);
	
	ПроцессорВывода.НачатьВывод();
	
	Пока Истина Цикл
    	ЭлементРезультата = ПроцессорКомпоновки.Следующий();
    	Если ЭлементРезультата= Неопределено Тогда
        	Прервать;
		Иначе						
        	ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);			
        КонецЕсли;
    КонецЦикла;
  
	ПроцессорВывода.ЗакончитьВывод();
	
КонецПроцедуры

 

 

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

14 Коммент.

  1. отредактировал запись, теперь с примером, надеюсь понятно, и так все отчёты уже устал, что делать посоветуйте!!!! Ещё раз обращаю ваше внимание – ВСЕ ОБЛАСТИ ВЫДЕЛЕНЫ ПРАВИЛЬНО!!!

  2. Посмотри на вкладке “Макеты” для шапки таблицы какой у тебя выбран макет: МакетПоля или МакетГруппировкиЗаголовка(на рисунке просто не видно). Должен быть второй (на Пиктограмме должен быть зеленый прямоугольник).

    И в настройках вывода не надо выводить шапку таблицы, она по умолчанию сама выводится. А также на вкладке “Другие настройки” укажи “Макет оформления – Без оформления”.
    Должно помочь.

    • Макет группировки для всех областей стоит. “в настройках вывода не надо выводить шапку таблицы, она по умолчанию сама выводится” – это где я чёт не нашёл????

      • Это во втором рисунке настройки вывода – ” (шапка)” – попробуй удалить.
        Далее по макетам:
        1. Для заголовка отчета и шапки таблицы – макет заголовка группировки
        2. Для вывода группировок – макет группировки
        3. Для детальных записей – макет поля

        • пробовал и раньше, если я ставлю “макет заголовка группировки”, то у меня макет вообще не выводится только данные(((( уже устал бороться 6 отчётов и все с пустыми строками после шапки таблицы и перед итогом((((( здесь что-то другое, но пока не знаю что!!! Что посоветуете???

      • Попробуй сделать так:
        1.В макете
        1.1. Для заголовка отчета и шапки таблицы – макет заголовка группировки (для группировки ВидТоплива)
        1.2. Для группировки “ВидТоплива” – макет группировки
        1.3. Для детальных записей – макет поля

        2. В настройках СКД:
        2.1 Убрать вывод шапки
        2.2. Сделать такую настройку:
        2.2.1. ВидТоплива
        2.2.2. Детальные записи

        3. На вкладке “Другие настройки” указать макет оформления “Без оформления”

        Если сделать так, то с вероятностью 95% проблемма исчезнет

  3. Проблема-то решилась ? А то тоже вот столкнулся. Лишний раз выводится группировка с пустыми данными… :( Наблюдение – иногда помогает полная пересборка схемы компоновки, но задолбало страшно – макет-то рисуется последним !!!

  4. dlis, а пересборка помогает ? Если заново схему создать, скопировав запрос ?? Есть одна тонкость – глюк сам-по-себе, а лишний вывод группировки может вызываться ещё и другими причинами, например в выборке могут присутствовать записи, поля которых в макет не попадают, но процессор строку под них выделяет всё равно… Это я в плане обмена опытом 😉

  5. Столкнулась с той же проблемой – самонарисованный макет и перед группировками (находящимися либо после цепочки последовательно подчиненных группировок, либо до неё) выводило пустые строки.
    Потыкалась-помыкалась и переключила для проблемных группировок на закладке “Другие настройки” настройку “Вариант использования группировки” с положения “Авто” на “Дополнительная информация”, и.. О чудо! всё в отчете отрисовалась как надо. Это называется, “потыкать всё подряд от безысходности”. :)
    Если этот вариант не помогает, то вероятнее всего пустые строки присутствуют в выборке и от них можно отделаться элементарным отбором.

Оставить комментарий

RSSКомментарии в RSS

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.