Посты с тэгами "XML"

Смена типа набора данных СКД с сохранением полей

Ваш отзывFavoriteLoadingВ закладки

Иногда возникает необходимость в существующем отчете на СКД, имеющем набор данных – запрос, изменить тип набора данных с запроса на объект, например, при необходимости поместить данные в таблицу значений, затем передать ее в СКД в качестве набора данных – объект. При этом, придется заново настраивать поля СКД (роли, оформление и пр.), ресурсы, что может занять немало времени. В этой статье пойдет речь о том, как сменить тип набора данных с сохранением всех настроенных полей.

Пусть, мы имеем отчет, построенный на СКД с набором данных – запрос. У полей отчета настроены роли и некое оформление.

Смена типа СКД 1

Иногда возникает необходимость в существующем отчете на СКД, имеющем набор данных – запрос, изменить тип набора данных с запроса на объект, например, при необходимости поместить данные в таблицу значений, затем передать ее в СКД в качестве набора данных – объект. При этом, придется заново настраивать поля СКД (роли, оформление и пр.), ресурсы, что может занять немало времени. В этой статье пойдет речь о том, как сменить тип набора данных с сохранением всех настроенных полей. Пусть, мы имеем отчет, построенный на СКД с набором данных – запрос. У полей отчета настроены роли и некое оформление....

Далее

Как программно установить схему их XML

Ваш отзывFavoriteLoadingВ закладки

Для того, чтобы программно установить схему их XML файла, необходимо выполнить следующее:

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Фильтр = "Файлы XML (*.xml) |*.xml";
Если НЕ Диалог.Выбрать() Тогда
   Возврат;
КонецЕсли;

ЧтениеXML = Новый ЧтениеXML;

Попытка
   ЧтениеXML.ОткрытьФайл(Диалог.ПолноеИмяФайла);
Исключение
   Сообщить("Невозможно открыть xml-файл");
   Возврат;
КонецПопытки;

СхемаКомпоновкиДанных = СериализаторXDTO.ПрочитатьXML(ЧтениеXML,
                                      ,Тип("СхемаКомпоновкиДанных"));

ЧтениеXML.Закрыть();

Теперь в переменной СхемаКомпоновкиДанных содержится схема, с которой можно делать что угодно. Например сформировать отчет по примеру отсюда.

Для того, чтобы программно установить схему их XML файла, необходимо выполнить следующее: Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); Диалог.Фильтр = "Файлы XML (*.xml) |*.xml"; Если НЕ Диалог.Выбрать() Тогда Возврат; КонецЕсли; ЧтениеXML = Новый ЧтениеXML; Попытка ЧтениеXML.ОткрытьФайл(Диалог.ПолноеИмяФайла); Исключение Сообщить("Невозможно открыть xml-файл"); Возврат; КонецПопытки; СхемаКомпоновкиДанных = СериализаторXDTO.ПрочитатьXML(ЧтениеXML, ,Тип("СхемаКомпоновкиДанных")); ЧтениеXML.Закрыть(); Теперь в переменной СхемаКомпоновкиДанных содержится схема, с которой можно делать что угодно. Например сформировать отчет по примеру отсюда. Перейти к...

Далее

Как программно сохранить схему в XML

Ваш отзывFavoriteLoadingВ закладки

Как программно сохранить схему в XML, аналогично тому как это делается по кнопке “Сохранить схему в файл”?

ЗаписьXML = Новый ЗаписьXML;

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
Диалог.Фильтр = "Файлы XML (*.xml) |*.xml";
Если НЕ Диалог.Выбрать() Тогда
    Возврат;
КонецЕсли;

Путь = Диалог.ПолноеИмяФайла;
ЗаписьXML.ОткрытьФайл(Путь);

СериализаторXDTO.ЗаписатьXML(ЗаписьXML,
ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"), 
"dataComposition",
"http://v8.1c.ru/8.1/data-composition-system/composition-template");
Как программно сохранить схему в XML, аналогично тому как это делается по кнопке “Сохранить схему в файл”? ЗаписьXML = Новый ЗаписьXML; Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение); Диалог.Фильтр = "Файлы XML (*.xml) |*.xml"; Если НЕ Диалог.Выбрать() Тогда Возврат; КонецЕсли; Путь = Диалог.ПолноеИмяФайла; ЗаписьXML.ОткрытьФайл(Путь); СериализаторXDTO.ЗаписатьXML(ЗаписьXML, ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"), "dataComposition", "http://v8.1c.ru/8.1/data-composition-system/composition-template"); Перейти к...

Далее

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.