Две СКД схемы в одном отчете, Просьба помочь с исправлением кода

1 отзывFavoriteLoadingВ закладки

На форме 2 переключателя – первый вариант и второй вариант, Суть проблемы – при формировании по первому варианту – все хорошо отчет формируеться все как надо при выборе на форме второго варианта
выдает ошибку “{Форма.ФормаОтчета(395)}: Ошибка при вызове метода контекста (Выполнить): Ошибка компоновки макета
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
по причине:
Ошибка компоновки макета
по причине:
Не установлено значение параметра “КонПериода””
если установить снова на первый пункт флаг то снова формирует все красиво
привожу код:

Перем предупр;

Процедура ВыбПериодНажатие(Элемент)
НастройкаПериода = Новый НастройкаПериода;
НастройкаПериода.УстановитьПериод(НачПер, ?(КонПер=’0001-01-01′, КонПер, КонецДня(КонПер)));
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
Если НастройкаПериода.Редактировать() Тогда
НачПер = НастройкаПериода.ПолучитьДатуНачала();
КонПер = НастройкаПериода.ПолучитьДатуОкончания();
КонецЕсли;
КонецПроцедуры

На форме 2 переключателя – первый вариант и второй вариант, Суть проблемы – при формировании по первому варианту – все хорошо отчет формируеться все как надо при выборе на форме второго варианта выдает ошибку “{Форма.ФормаОтчета(395)}: Ошибка при вызове метода контекста (Выполнить): Ошибка компоновки макета МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки); по причине: Ошибка компоновки макета по причине: Не установлено значение параметра “КонПериода”” если установить снова на первый пункт флаг то снова формирует все красиво привожу код: Перем предупр; Процедура ВыбПериодНажатие(Элемент) НастройкаПериода = Новый НастройкаПериода; НастройкаПериода.УстановитьПериод(НачПер, ?(КонПер=’0001-01-01′, КонПер, КонецДня(КонПер))); НастройкаПериода.РедактироватьКакИнтервал = Истина; НастройкаПериода.РедактироватьКакПериод = Истина; НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период; Если НастройкаПериода.Редактировать() Тогда НачПер = НастройкаПериода.ПолучитьДатуНачала(); КонПер = НастройкаПериода.ПолучитьДатуОкончания(); КонецЕсли; КонецПроцедуры...

Далее

Отчет РасчетныеВедомостиОрганизаций

Отзывов (3)FavoriteLoadingВ закладки

Доброго времени суток, помогите пожалуйста доработать отчет “РасчетныеВедомостиОрганизаций” для ЗиКБУ. Задача на первый взгляд простая: добавить колонку СуммаКВыплате = ВсегоНачислено-ВсегоУдержано. Ковырялся целый день, к сожалению знаний по СКД мало, поэтому ничего не вышло…
Заранее благодарен.

Доброго времени суток, помогите пожалуйста доработать отчет “РасчетныеВедомостиОрганизаций” для ЗиКБУ. Задача на первый взгляд простая: добавить колонку СуммаКВыплате = ВсегоНачислено-ВсегоУдержано. Ковырялся целый день, к сожалению знаний по СКД мало, поэтому ничего не вышло… Заранее благодарен. Перейти к...

Далее

Итоги по условию поля

Отзывов (2)FavoriteLoadingВ закладки

Подскажите, можно ли такое сделать?
Чтобы итоги “Всего работающих, из них” выводил не по всем строкам, а только по строкам не совместителей
(скрин во вложении)Настройки1 Настройки2 Настройки3

Подскажите, можно ли такое сделать? Чтобы итоги “Всего работающих, из них” выводил не по всем строкам, а только по строкам не совместителей (скрин во вложении) Перейти к...

Далее

Программный отбор в СКД

1 отзывFavoriteLoadingВ закладки

Задача такая: необходимо в СКД сделать так, что бы в отчет попала Номенклатура, которая наиболее соответствует (по принципу ПОДОБНО или Содержит) одному из элементов таблицы значений ТаблЗнач. (Номенклатура и ТаблЗнач ключей по связи не имеют).

Задача такая: необходимо в СКД сделать так, что бы в отчет попала Номенклатура, которая наиболее соответствует (по принципу ПОДОБНО или Содержит) одному из элементов таблицы значений ТаблЗнач. (Номенклатура и ТаблЗнач ключей по связи не имеют). Перейти к...

Далее

IV профессиональная конференция INFOSTART EVENT 2014. IV конференция INFOSTART EVENT 2014

Ваш отзывFavoriteLoadingВ закладки

29-31 октября 2014 года в Концертном зале «Колизей» на Невском, 100 в Санкт-Петербурге состоялась IV профессиональная конференция INFOSTARTEVENT 2014 – самое значительное и ставшее уже традиционным мероприятие по управлению проектами и профессиональной разработке на платформе 1С: Предприятие.

Конференция, организованная профессиональным Сообществом по автоматизации учета и управления Infostart.ru – самым многочисленным (более 430 000 зарегистрированных участников) сообществом Рунета, – собрала под своей эгидой представителей таких компаний, как Трансойл, Магнатэк, Вита-страхование, Балтстройкомплектация, Газпром-нефть, Деловые линии, Мегафон Ритейл, ТГК-1, SetlGroup, ЕвроСибЭнерго, Связной, 1С-Рарус, О`Кей, Лукойл, КРОК, ТехноНИКОЛЬ и многих других.

29-31 октября 2014 года в Концертном зале «Колизей» на Невском, 100 в Санкт-Петербурге состоялась IV профессиональная конференция INFOSTARTEVENT 2014 – самое значительное и ставшее уже традиционным мероприятие по управлению проектами и профессиональной разработке на платформе 1С: Предприятие. Конференция, организованная профессиональным Сообществом по автоматизации учета и управления Infostart.ru – самым многочисленным (более 430 000 зарегистрированных участников) сообществом Рунета, – собрала под своей эгидой представителей таких компаний, как Трансойл, Магнатэк, Вита-страхование, Балтстройкомплектация, Газпром-нефть, Деловые линии, Мегафон Ритейл, ТГК-1, SetlGroup, ЕвроСибЭнерго, Связной, 1С-Рарус, О`Кей, Лукойл, КРОК, ТехноНИКОЛЬ и многих других....

Далее

СКД как источник данных для подсистемы планирования

1 отзывFavoriteLoadingВ закладки

Здравствуйте.

Задумал использовать общий макет СКД для получения одних и тех же данных (для планирования закупа). Например такие данные как остаток на начало текущего месяца, товары в пути, неликвидный товар, продажи прошлых 6 месяцев за каждый месяц отдельно.

Все это нужно выводить в виде дерева, в разрезе основных свойств характеристик. Основные свойства характеристик задаются в периодическом регистре сведений.

Отбирать нужно по подразделению и периоду. Когда выяснилось, что иногда отбирать нужно по складу, тут я встрял.

Здравствуйте. Задумал использовать общий макет СКД для получения одних и тех же данных (для планирования закупа). Например такие данные как остаток на начало текущего месяца, товары в пути, неликвидный товар, продажи прошлых 6 месяцев за каждый месяц отдельно. Все это нужно выводить в виде дерева, в разрезе основных свойств характеристик. Основные свойства характеристик задаются в периодическом регистре сведений. Отбирать нужно по подразделению и периоду. Когда выяснилось, что иногда отбирать нужно по складу, тут я встрял....

Далее

Как запретить изменять группировку СКД

1 отзывFavoriteLoadingВ закладки

Как запретить менять группировку, в скд в ресурсах привязано к функции Уровень() много чего, после изменения уровня сменой группировок итоги ясное дело полетят, есть возможность?

Как запретить менять группировку, в скд в ресурсах привязано к функции Уровень() много чего, после изменения уровня сменой группировок итоги ясное дело полетят, есть возможность? Перейти к...

Далее
Страница 6 из 45« Первая...45678...203040...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.