Как посчитать дельту

Отзывов (5)FavoriteLoadingВ закладки

Формирую отчет по закупочным ценам и как определить дельту между закупочными цена, как показано на рисунке?

 

 

 

Формирую отчет по закупочным ценам и как определить дельту между закупочными цена, как показано на рисунке?       Перейти к...

Далее

Получаю неправильные настройки для СКД при использовании нескольких макетов СКД в одном отчете

Ваш отзывFavoriteLoadingВ закладки

В форме в процедуре ПриИзмененииВариатыСКД

Упрощённо:

Если Отчет.ВариатыСКД = 1 Тогда

СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Первый”);

Иначе

СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Второй”);

КонецЕсли;

URLКомпоновки = ПоместитьВоВременноеХранилище(СКД);
Отчет.КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(URLКомпоновки));
Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(СКД.НастройкиПоУмолчанию);
Отчет.КомпоновщикНастроек.Восстановить(СпособВосстановленияНастроекКомпоновкиДанных.Полное);

В модуле в Процедуре ПриКомпоновкеРезультата

:

Если ЭтотОбъект.ВариатыСКД = 1 Тогда

СКД = ЭтотОбъект.ПолучитьМакет(“Первый”);

Иначе

СКД = ЭтотОбъект.ПолучитьМакет(“Второй”);

КонецЕсли;

НастройкиСКД = ЭтотОбъект.КомпоновщикНастроек.ПолучитьНастройки();

Смотрю в отладчике значение НастройкиСКД.ДоступныеПоляДополнительныхОтборов – выдаёт список отборов из другого макета СКД.

А если заменить в модуле НастройкиСКД на

НастройкиСКД = СКД.НастройкиПоУмолчанию;

тогда НастройкиСКД.ДоступныеПоляДополнительныхОтборов выдаёт правильный список отборов,   но,  конечно с значениями по умолчанию.

В форме в процедуре ПриИзмененииВариатыСКД Упрощённо: Если Отчет.ВариатыСКД = 1 Тогда СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Первый”); Иначе СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Второй”); КонецЕсли; URLКомпоновки = ПоместитьВоВременноеХранилище(СКД); Отчет.КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(URLКомпоновки)); Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(СКД.НастройкиПоУмолчанию); Отчет.КомпоновщикНастроек.Восстановить(СпособВосстановленияНастроекКомпоновкиДанных.Полное); В модуле в Процедуре ПриКомпоновкеРезультата … : Если ЭтотОбъект.ВариатыСКД = 1 Тогда СКД = ЭтотОбъект.ПолучитьМакет(“Первый”); Иначе СКД = ЭтотОбъект.ПолучитьМакет(“Второй”); КонецЕсли; НастройкиСКД = ЭтотОбъект.КомпоновщикНастроек.ПолучитьНастройки(); … Смотрю в отладчике значение НастройкиСКД.ДоступныеПоляДополнительныхОтборов – выдаёт список отборов из другого макета СКД. А если заменить в модуле НастройкиСКД на НастройкиСКД = СКД.НастройкиПоУмолчанию; тогда НастройкиСКД.ДоступныеПоляДополнительныхОтборов выдаёт правильный список отборов,   но,  конечно с значениями по умолчанию....

Далее

Помогите новичку – Операция с Датой

Отзывов (2)FavoriteLoadingВ закладки

Не могу разобраться с полем ВЫРАЖЕНИЕ на вкладке ПАРАМЕТРЫ в окне редактирования СКД в Конфигураторе… дело все в том. что например есть там две строки – НачалоПериода и КонецПериода – какое нужно написать там выражение, что бы произошло вычисление по результатом доступного для пользователя поля КонецПериода? то есть. он вводит в это поле значение например 18.04.13, и в поле НачалоПериода выражением будет подставлена дата = КонецПериода – Месяц?

Не могу разобраться с полем ВЫРАЖЕНИЕ на вкладке ПАРАМЕТРЫ в окне редактирования СКД в Конфигураторе… дело все в том. что например есть там две строки – НачалоПериода и КонецПериода – какое нужно написать там выражение, что бы произошло вычисление по результатом доступного для пользователя поля КонецПериода? то есть. он вводит в это поле значение например 18.04.13, и в поле НачалоПериода выражением будет подставлена дата = КонецПериода – Месяц? Перейти к...

Далее

Вопрос с шапками СКД

1 отзывFavoriteLoadingВ закладки

Доброго всем части суток!

Возникла проблемка:

Предположим есть отчет в нем 2 таблицы с шапками:

Контрагент                      Количество

ООО”Контрагент”            3

 

Контрагент                Договор    Количество  Цена

ООО”Контрагент”   Договор1   1                           100

ООО”Контрагент”   Договор2    2                          200

При печати ,Если отчет на несколько страниц,повторяется шапка 1 таблицы то есть выглядит вот так

Контрагент   Количество

ООО”Контрагент”   Договор1     1     100

Вопрос: Как Сделать так чтоб при печати повторялась шапка второй таблицы ,а не первой? или же вообще не повторялось? Заранее спасибо!

 

 

Доброго всем части суток! Возникла проблемка: Предположим есть отчет в нем 2 таблицы с шапками: Контрагент                      Количество ООО”Контрагент”            3   Контрагент                Договор    Количество  Цена ООО”Контрагент”   Договор1   1                           100 ООО”Контрагент”   Договор2    2                          200 При печати ,Если отчет на несколько страниц,повторяется шапка 1 таблицы то есть выглядит вот так Контрагент   Количество ООО”Контрагент”   Договор1     1     100 Вопрос: Как Сделать так чтоб при печати повторялась шапка второй таблицы ,а не первой? или же вообще не повторялось? Заранее спасибо!     Перейти к...

Далее

СКД получить значение группировки вышестоящего уровня

Ваш отзывFavoriteLoadingВ закладки

 

Товарная марка Кол SKU в марке
BENXI 2
BJ-GDB&S 48
BJ–decor 338
Организация BENXI BJ-GDB&S BJ–decor
Контрагент SKU Доля SKU Доля SKU Доля
Моя организация
    Клиент1 15 24
    Клиент2 7
    Клиент3 18 14

Помогите!!! Как во вторую таблицу подтянуть данные из первой, т.е. сколько всего СКЮ имеется по товарной марке?

  Товарная марка Кол SKU в марке BENXI 2 BJ-GDB&S 48 BJ–decor 338 Организация BENXI BJ-GDB&S BJ–decor Контрагент SKU Доля SKU Доля SKU Доля Моя организация     Клиент1 15 24     Клиент2 7     Клиент3 18 14 Помогите!!! Как во вторую таблицу подтянуть данные из первой, т.е. сколько всего СКЮ имеется по товарной марке? Перейти к...

Далее

Перераспределение остатков “внутренних” партий на “внешние” партии по датам.

Ваш отзывFavoriteLoadingВ закладки

Суть: “внешние партии” – партии, поступления пришедшие в организацию из вне, которые идут либо конечным либо “своим” контрагентам, “внутренние партии” – партии реализованые “своим” контрагентам оформляются через документ “Внутренний заказ” с последующим вводом пары документов “Реализация” и “Поступление” для каждого такого внутреннего заказа (упрощенно это можно понимать как перемещение товара на склад другого подразделения, по крайней мере логика такова)

Необходимо: учесть остатки товара по “внутренней партии” на остатках товара на “внешней”

Реализация запросом:

Суть: “внешние партии” – партии, поступления пришедшие в организацию из вне, которые идут либо конечным либо “своим” контрагентам, “внутренние партии” – партии реализованые “своим” контрагентам оформляются через документ “Внутренний заказ” с последующим вводом пары документов “Реализация” и “Поступление” для каждого такого внутреннего заказа (упрощенно это можно понимать как перемещение товара на склад другого подразделения, по крайней мере логика такова) Необходимо: учесть остатки товара по “внутренней партии” на остатках товара на “внешней” Реализация запросом:...

Далее

Сравнение значений в разных группировках

Отзывов (4)FavoriteLoadingВ закладки

Доброго времени суток!

Надо сравнить значения показателя в разных группировках.

В общем случае Показатель2 может иметь несколько значений (в данном случае 3 варианта).  Требуется:

1. в отчет вывести два значения показателя.

По идее легко настраивается через отборы в группе ИЛИ.

2. вычислить разницу между значениями этих показателей (Поле Отклонение).

А вот с этим – не знаю как сделать. В идеале хотелось бы через вычисляемое поле, т.к. данные для отчета поступают из двух внешних источников и что-то с ними сделать довольно сложно.

Попробовал через Вычисляемое поле – задал выражение

новое Поле с названием СуммаПлан1

Доброго времени суток! Надо сравнить значения показателя в разных группировках. В общем случае Показатель2 может иметь несколько значений (в данном случае 3 варианта).  Требуется: 1. в отчет вывести два значения показателя. По идее легко настраивается через отборы в группе ИЛИ. 2. вычислить разницу между значениями этих показателей (Поле Отклонение). А вот с этим – не знаю как сделать. В идеале хотелось бы через вычисляемое поле, т.к. данные для отчета поступают из двух внешних источников и что-то с ними сделать довольно сложно. Попробовал через Вычисляемое поле – задал выражение новое Поле с названием СуммаПлан1...

Далее
Страница 48 из 77« Первая...102030...4647484950...6070...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.