Авторы, присоединяйтесь!

Отзывов (4)FavoriteLoadingВ закладки

Еще раз всем доброго времени суток! Наш ресурс начинает активно развиваться. Уже зарегистрировалось около 200 пользователей…Толи еще будет! Авторы, не стесняйтесь, и делитесь своими материалами.

Для того, чтобы добавить статью необходимо зарегистрироваться. Для вас станет доступным удобная админка для просмотра и редактирования записей. Попасть в нее можно через кнопку “Добавить статью”:

Еще раз всем доброго времени суток! Наш ресурс начинает активно развиваться. Уже зарегистрировалось около 200 пользователей…Толи еще будет! Авторы, не стесняйтесь, и делитесь своими материалами. Для того, чтобы добавить статью необходимо зарегистрироваться. Для вас станет доступным удобная админка для просмотра и редактирования записей. Попасть в нее можно через кнопку “Добавить статью”: Также рекомендуем прочитать статью Рекомендации к публикации статей Ждем от Вас новых поступлений! Удачи!...

Далее

Примеры отчетов на СКД

Отзывов (4)FavoriteLoadingВ закладки

О разработке

Отличный набор примеров по работе с СКД. В первые был опубликован здесь.

В данной публикации приведены следующие примеры отчетов на СКД:

1. Сортировка одного поля по другому (без вывода этого доп. поля)

2. СКД в обработке:
Пример ручного формирования отчета во внешней обработке (для возможности подключения как печ. форму)

3. СКД (Только отбор):
Использование отбора СКД при ручном формировании отчета

4. Защита СКД:
Схема храниться в макете в виде zip архива с паролем

5. Остатки и таблица значений:
Использование ролей полей для получения отчета по остакам с разворотом по дополнительным периодам

6. По всем контрагентам:
Дополнение отчета всеми контрагентами (через объединение наборов)

7. Вложенные схемы

8. Объединение наборов данных:
Вычисление разных ресурсов на разных уровнях

9. Два отчета в 1 схеме

10. Две схемы в одном отчете

11. Остатки и движения по вертикали
Дополнение движений строками: “Остатки на []”

12. Модуль “ПроцедурыРаботыСКомпоновкой”:

ПолучитьПараметрОтчета()
УстановитьПараметрОтчета()
НайтиГруппировку()
ОтборПоНепустым()
УстановитьПользовательскоеПолеИнтервал()

13. Подсистема “Шаблон типового отчета”:
Формы, модули, справочники и т.д. из БП 1.6.13 необходимые для работы
отчета “Шаблон типового отчета”

О разработке Отличный набор примеров по работе с СКД. В первые был опубликован здесь. В данной публикации приведены следующие примеры отчетов на СКД: 1. Сортировка одного поля по другому (без вывода этого доп. поля) 2. СКД в обработке: Пример ручного формирования отчета во внешней обработке (для возможности подключения как печ. форму) 3. СКД (Только отбор): Использование отбора СКД при ручном формировании отчета 4. Защита СКД: Схема храниться в макете в виде zip архива с паролем 5. Остатки и таблица значений: Использование ролей полей для получения отчета по остакам с разворотом по дополнительным периодам 6. По всем контрагентам: Дополнение отчета всеми контрагентами (через объединение наборов) 7. Вложенные схемы 8. Объединение наборов данных: Вычисление разных ресурсов на разных уровнях 9. Два отчета в 1 схеме 10. Две схемы в одном отчете 11. Остатки и движения по вертикали Дополнение движений строками: “Остатки на []” 12. Модуль “ПроцедурыРаботыСКомпоновкой”: ПолучитьПараметрОтчета() УстановитьПараметрОтчета() НайтиГруппировку() ОтборПоНепустым() УстановитьПользовательскоеПолеИнтервал() 13. Подсистема “Шаблон типового отчета”: Формы, модули, справочники и т.д. из БП 1.6.13 необходимые для работы отчета “Шаблон типового отчета” Скриншоты Скачать все файлы одним архивом...

Далее

Отчет по движениям документа

Отзывов (2)FavoriteLoadingВ закладки

Данная обработка является аналогом известной обработки используемой во всех типовых конфигурациях. За одним лишь исключением – данная обработка написана с использованием СКД. Схема компоновки полностью динамическая. Формируется исходя из движений документа.  Платформа 8.2. Толстый клиент. Код открыт.

Скачать

Данная обработка является аналогом известной обработки используемой во всех типовых конфигурациях. За одним лишь исключением – данная обработка написана с использованием СКД. Схема компоновки полностью динамическая. Формируется исходя из движений документа.  Платформа 8.2. Толстый клиент. Код открыт. Скачать Перейти к...

Далее

Как программно сохранить схему в XML

Ваш отзывFavoriteLoadingВ закладки

Как программно сохранить схему в XML, аналогично тому как это делается по кнопке “Сохранить схему в файл”?

ЗаписьXML = Новый ЗаписьXML;

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
Диалог.Фильтр = "Файлы XML (*.xml) |*.xml";
Если НЕ Диалог.Выбрать() Тогда
    Возврат;
КонецЕсли;

Путь = Диалог.ПолноеИмяФайла;
ЗаписьXML.ОткрытьФайл(Путь);

СериализаторXDTO.ЗаписатьXML(ЗаписьXML,
ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"), 
"dataComposition",
"http://v8.1c.ru/8.1/data-composition-system/composition-template");
Как программно сохранить схему в XML, аналогично тому как это делается по кнопке “Сохранить схему в файл”? ЗаписьXML = Новый ЗаписьXML; Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение); Диалог.Фильтр = "Файлы XML (*.xml) |*.xml"; Если НЕ Диалог.Выбрать() Тогда Возврат; КонецЕсли; Путь = Диалог.ПолноеИмяФайла; ЗаписьXML.ОткрытьФайл(Путь); СериализаторXDTO.ЗаписатьXML(ЗаписьXML, ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"), "dataComposition", "http://v8.1c.ru/8.1/data-composition-system/composition-template"); Перейти к...

Далее

Универсальная консоль отчетов (8.1)

Отзывов (22)FavoriteLoadingВ закладки

О разработке

На данный момент, пожалуй лучшая консоль СКД и не только. Огромнейший функционал. Автором проделана просто невероятная работа! Позволяет в режиме предприятия создать отчет на СКД и экспортировать его во внешний отчет с выбором шаблона.

Универсальная консоль отчетов (тек. версия 2.7.7). Автор разработки Evg-Lylyk.

Из функций:
1. Работает в любой конфигурации
2. Возможность создания произвольной иерархии с удобным переносом элементов
3. Расширенное редактирование параметров (периоды, насл. параметры)
4. Выполнение в фоне (без модификации конфигурации)
5. Сравнение текстов запросов и результатов запроса
6. СКД
Гибкость удобство и настраиваемость. Код открыт.
Регистрация пожеланий и исправление ошибок через http://www.1cpp.ru/bugs/ проект Консоль запросов для 1С 8.1 (желательно)

О разработке На данный момент, пожалуй лучшая консоль СКД и не только. Огромнейший функционал. Автором проделана просто невероятная работа! Позволяет в режиме предприятия создать отчет на СКД и экспортировать его во внешний отчет с выбором шаблона. Универсальная консоль отчетов (тек. версия 2.7.7). Автор разработки Evg-Lylyk. Из функций: 1. Работает в любой конфигурации 2. Возможность создания произвольной иерархии с удобным переносом элементов 3. Расширенное редактирование параметров (периоды, насл. параметры) 4. Выполнение в фоне (без модификации конфигурации) 5. Сравнение текстов запросов и результатов запроса 6. СКД Гибкость удобство и настраиваемость. Код открыт. Регистрация пожеланий и исправление ошибок через http://www.1cpp.ru/bugs/ проект Консоль запросов для 1С 8.1 (желательно) Основные возможности 1. В списке запросов можно создавать группы и выделять элементы. 2. Вывод в таблицу, дерево, макет, сводный отчет. 3. Подсчет итогов в по колонке в таблице и дереве. 4. Подсчет суммы выделения в макете. 5. Выполнение в фоне. 6. Функция показать последний результат. 7. В меню файл есть список последних открытых файлов. 8. Сравнение текстов запросов и результатов запроса. 9. Формат полей 10. Замер времени выполнения. 11. Drag & Drop в дереве и в настройках построителя. 12. Вывод копии в Excel, HTML, CSV. 13. Генерация текста на встроенном языке. 14. Более удобный ввод параметра списка и составного параметра. 15. Группировка параметров НачПериода,КонПериода и аналогичных в группу. 16. Наследованный параметр значение которого берется из другого запроса. 17. Заполнение параметров из другого запроса. 18. Параметры и их значения запоминаются и подставляются при использовании одноименного параметра. 19. Многократное выполнение запроса для теста. 20. Можно открыть консоль в режиме отладки при этом автоматически будут получены параметры для отладки необходима вызвать процедуру “ОткрытьДляОтладки” из модуля обработки передав ей в качетве параметра объекты “Запрос” Или “ПостроительОтчета”, “ПостроительЗапроса”, “СхемаКомпоновкиДанных” для объекта ПостроительОтчета будут также получены настройки построителя. Когда консоль открыта для отладки в заголовке добавляется текст (отладка). Пример: Выражение= ВнешниеОбработки.Создать (“C:д_КонсольОтчетов2.3.epf”).ОткрытьДляОтладки(ЗапросТовары); 21. Подсказки в трее в случае окончания долгого запроса или фонового выполнения. 22. Групповая обработка данных 23. Редактируемы макет 24. Параметр значение которого получается выполнением текста на встроенном языке 25. Переименование параметров без ипользования констроктора прямо из Таблицы параметры 26. СКД 27. Интуитивное заполнение значений параметров 28. Контекстная  подсказка 29. Есть возможность импортировать rcf файлы от стандартной консоли 1С и dcf файлы стандартной консоли компоновки от 1С и sel формат консоли ИР. 30. Конвертация текста запроса в TSQL 31. Анализ данных 32. Пользователский режим 33. Экспорт в CSV 34. Функции менеджера обработок 35. В таблице и дереве результата значения типа NULL выделяются цветом и текстом “Null” 36. Генерация внешней обработки на основе СКД (Статья “Удобный конструктор внешних отчетов на СКД”) Скриншоты Скачать Универсальная консоль отчетов 2.7.7.rar(1.54 Мб)...

Далее

Как в СКД накрыть колонки шапкой

Отзывов (16)FavoriteLoadingВ закладки

Данный вопрос возникает у пользователей СКД достаточно часто. Сразу отмечу, что данную задачу можно решить несколькими способами, но все они не совсем очевидные. Предлагаю, на мой взгляд, самый простой и эффективный способ решения этой задачи.

Данный вопрос возникает у пользователей СКД достаточно часто. Сразу отмечу, что данную задачу можно решить несколькими способами, но все они не совсем очевидные. Предлагаю, на мой взгляд, самый простой и эффективный способ решения этой задачи. Имеем простой отчет на компоновке вида: Теперь сделаем шапку “Оборот” над колонками “Количество оборот” и “Стоимость оборот”, а колонки назовем “Количество” и “Стоимость”. Для это зайдем на вкладку “Наборы данных” конструктора СКД и немного пошаманим. Находим поля “КоличествоОборот и “СтоимостьОборот” и меняем у них путь. Полю “КоличествоОборот” меняем путь на “Оборот.КоличествоОборот”, аналогично меняем у стоимости. Также изменяем заголовки: Теперь перейдем на вкладку “Настройки” и в выбранных полях выберем группу “Оборот”: Сформируем отчет: Вроде получилось. Единственное, наверное многим захочется расположить шапку по центру. Конечно можно нарисовать свой макет оформления, но считаю в данном случае это не стоит того. Поэтому предлагаю просто использовать пробелы в названии группы. В нашем случае название группы будет таким: ”              Оборот”, а вид отчета таким:...

Далее

Как изменить отбор программно

Ваш отзывFavoriteLoadingВ закладки

Эта тема тоже достаточна распространена. Нюанс программного изменения отбора заключается в том, что коллекция:

КомпоновщикНастроек.Настройки.Отбор.Элементы

в отличие от аналогичной коллекции параметров, не имеет метода Найти(). Можно конечно изменять отбор “в лоб”, т.е. по индексу, но это не есть хорошо. Самый оптимальный вариант, обходить все поля отбора в цикле.

Приведу пример универсальной функции для изменения отбор компоновки данных:

Эта тема тоже достаточна распространена. Нюанс программного изменения отбора заключается в том, что коллекция: КомпоновщикНастроек.Настройки.Отбор.Элементы в отличие от аналогичной коллекции параметров, не имеет метода Найти(). Можно конечно изменять отбор “в лоб”, т.е. по индексу, но это не есть хорошо. Самый оптимальный вариант, обходить все поля отбора в цикле. Приведу пример универсальной функции для изменения отбор компоновки данных: //Ищет отбор в компоновщике настроек по параметрам, заданным через //"СоответствиеПоискаОтбора", и заменяет //на отбор с параметрами, указанными в "СоответствиеНовогоОтбора" Процедура ИзменитьОтбор(ЭлементСтруктуры, СоответствиеПоискаОтбора = Неопределено, СоответствиеНовогоОтбора) Экспорт Если ТипЗнч(ЭлементСтруктуры) = Тип("КомпоновщикНастроекКомпоновкиДанных")  Тогда Отбор = ЭлементСтруктуры.Настройки.Отбор; Иначе Отбор = ЭлементСтруктуры; КонецЕсли; Если ТипЗнч(СоответствиеНовогоОтбора["ЛевоеЗначение"]) = Тип("Строка") Тогда нПоле = Новый ПолеКомпоновкиДанных(СоответствиеНовогоОтбора.ЛевоеЗначение); Иначе нПоле = СоответствиеНовогоОтбора["ЛевоеЗначение"]; КонецЕсли; Если СоответствиеНовогоОтбора.Получить("ВидСравнения") = Неопределено Тогда нВидСравнения = ВидСравненияКомпоновкиДанных.Равно; Иначе нВидСравнения = СоответствиеНовогоОтбора["ВидСравнения"]; КонецЕсли; Если СоответствиеНовогоОтбора.Получить("Использование") = Неопределено Тогда нИспользование = Истина; Иначе нИспользование = СоответствиеНовогоОтбора["Использование"]; КонецЕсли; нЗначение = СоответствиеНовогоОтбора["Значение"]; ТолькоПоЛевомуЗначению = Ложь; Если СоответствиеПоискаОтбора = Неопределено Тогда ТолькоПоЛевомуЗначению = Истина; КонецЕсли; сЛевоеЗначение = СоответствиеПоискаОтбора.Получить("ЛевоеЗначение"); Если сЛевоеЗначение = Неопределено Тогда сЛевоеЗначение = нПоле; КонецЕсли; сВидСравнения = СоответствиеПоискаОтбора.Получить("ВидСравнения"); Если ВидСравнения = Неопределено Тогда сВидСравнения = ВидСравнения; КонецЕсли; сИспользование = СоответствиеПоискаОтбора.Получить("Использование"); Если сИспользование = Неопределено Тогда сИспользование = нИспользование; КонецЕсли; Для каждого ЭлементОтбора Из Отбор.Элементы Цикл Если ТолькоПоЛевомуЗначению Тогда НайденныйОтбор = ЭлементОтбора; Прервать; Иначе Если (ЭлементОтбора.ЛевоеЗначение = сЛевоеЗначение) И (ЭлементОтбора.ВидСравнения = сВидСравнения) И (ЭлементОтбора.Использование = сИспользование) Тогда НайденныйОтбор = ЭлементОтбора; Прервать; КонецЕсли; КонецЕсли; КонецЦикла; Если НайденныйОтбор <> Неопределено Тогда НайденныйОтбор.ЛевоеЗначение = нПоле; НайденныйОтбор.Использование = нИспользование; НайденныйОтбор.ВидСравнения = нВидСравнения; НайденныйОтбор.ПравоеЗначение = нЗначение; КонецЕсли; КонецПроцедуры Пример вызова процедуры: СоответствиеПоискаОтбора = Новый Соответствие; СоответствиеПоискаОтбора.Вставить("ЛевоеЗначение",Новый ПолеКомпоновкиДанных("Наименование")); СоответствиеПоискаОтбора.Вставить("ВидСравнения",ВидСравненияКомпоновкиДанных.Содержит); СоответствиеПоискаОтбора.Вставить("Использование",Истина); СоответствиеНовогоОтбора = Новый Соответствие; СоответствиеНовогоОтбора.Вставить("ЛевоеЗначение",Новый ПолеКомпоновкиДанных("Наименование")); СоответствиеНовогоОтбора.Вставить("ВидСравнения",ВидСравненияКомпоновкиДанных.Содержит); СоответствиеНовогоОтбора.Вставить("Использование",Истина); СоответствиеНовогоОтбора.Вставить("Значение","бла-бла-бла"); ИзменитьОтбор(КомпоновщикНастроек,СоответствиеПоискаОтбора,СоответствиеНовогоОтбора);...

Далее
Страница 44 из 45« Первая...102030...4142434445

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.