Вопрос-ответ

Вывод итогов в отчете на скд

Отзывов (4)FavoriteLoadingВ закладки

Всем здравствуйте) Есть отчет по остаткам инструментов на складах, в нем выводится какие остатки на какой период были, как сделать что бы в итогах по номенклатуре выводились остатки на последний период? Пробовала прописать на закладке ресурсы следующее: Сумма(ВычислитьВыражениеСГруппировкойМассив(“ОстатокНаСкладе”, “Максимум(Период)”)); Но так не срабатывает. Пробовала писать: ВЫБОР КОГДА Период = &КонецПериода ТОГДА ОстатокНаСкладе КОНЕЦ; тоже не помогает. отчет отчет1

Всем здравствуйте) Есть отчет по остаткам инструментов на складах, в нем выводится какие остатки на какой период были, как сделать что бы в итогах по номенклатуре выводились остатки на последний период? Пробовала прописать на закладке ресурсы следующее: Сумма(ВычислитьВыражениеСГруппировкойМассив(“ОстатокНаСкладе”, “Максимум(Период)”)); Но так не срабатывает. Пробовала писать: ВЫБОР КОГДА Период = &КонецПериода ТОГДА ОстатокНаСкладе КОНЕЦ; тоже не помогает. Перейти к...

Далее

Убрать шапку таблицы в отчете

Отзывов (8)FavoriteLoadingВ закладки

Какими опциями (без использование макета) можно вообще
убрать шапку в таблице отчета, оставив только саму таблицу с данными (см рисунок).

Какими опциями (без использование макета) можно вообще убрать шапку в таблице отчета, оставив только саму таблицу с данными (см рисунок). Перейти к...

Далее

Две СКД схемы в одном отчете, Просьба помочь с исправлением кода

1 отзывFavoriteLoadingВ закладки

На форме 2 переключателя – первый вариант и второй вариант, Суть проблемы – при формировании по первому варианту – все хорошо отчет формируеться все как надо при выборе на форме второго варианта
выдает ошибку “{Форма.ФормаОтчета(395)}: Ошибка при вызове метода контекста (Выполнить): Ошибка компоновки макета
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
по причине:
Ошибка компоновки макета
по причине:
Не установлено значение параметра “КонПериода””
если установить снова на первый пункт флаг то снова формирует все красиво
привожу код:

Перем предупр;

Процедура ВыбПериодНажатие(Элемент)
НастройкаПериода = Новый НастройкаПериода;
НастройкаПериода.УстановитьПериод(НачПер, ?(КонПер=’0001-01-01′, КонПер, КонецДня(КонПер)));
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
Если НастройкаПериода.Редактировать() Тогда
НачПер = НастройкаПериода.ПолучитьДатуНачала();
КонПер = НастройкаПериода.ПолучитьДатуОкончания();
КонецЕсли;
КонецПроцедуры

На форме 2 переключателя – первый вариант и второй вариант, Суть проблемы – при формировании по первому варианту – все хорошо отчет формируеться все как надо при выборе на форме второго варианта выдает ошибку “{Форма.ФормаОтчета(395)}: Ошибка при вызове метода контекста (Выполнить): Ошибка компоновки макета МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки); по причине: Ошибка компоновки макета по причине: Не установлено значение параметра “КонПериода”” если установить снова на первый пункт флаг то снова формирует все красиво привожу код: Перем предупр; Процедура ВыбПериодНажатие(Элемент) НастройкаПериода = Новый НастройкаПериода; НастройкаПериода.УстановитьПериод(НачПер, ?(КонПер=’0001-01-01′, КонПер, КонецДня(КонПер))); НастройкаПериода.РедактироватьКакИнтервал = Истина; НастройкаПериода.РедактироватьКакПериод = Истина; НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период; Если НастройкаПериода.Редактировать() Тогда НачПер = НастройкаПериода.ПолучитьДатуНачала(); КонПер = НастройкаПериода.ПолучитьДатуОкончания(); КонецЕсли; КонецПроцедуры...

Далее

Итоги по условию поля

Отзывов (2)FavoriteLoadingВ закладки

Подскажите, можно ли такое сделать?
Чтобы итоги “Всего работающих, из них” выводил не по всем строкам, а только по строкам не совместителей
(скрин во вложении)Настройки1 Настройки2 Настройки3

Подскажите, можно ли такое сделать? Чтобы итоги “Всего работающих, из них” выводил не по всем строкам, а только по строкам не совместителей (скрин во вложении) Перейти к...

Далее

Программный отбор в СКД

1 отзывFavoriteLoadingВ закладки

Задача такая: необходимо в СКД сделать так, что бы в отчет попала Номенклатура, которая наиболее соответствует (по принципу ПОДОБНО или Содержит) одному из элементов таблицы значений ТаблЗнач. (Номенклатура и ТаблЗнач ключей по связи не имеют).

Задача такая: необходимо в СКД сделать так, что бы в отчет попала Номенклатура, которая наиболее соответствует (по принципу ПОДОБНО или Содержит) одному из элементов таблицы значений ТаблЗнач. (Номенклатура и ТаблЗнач ключей по связи не имеют). Перейти к...

Далее

СКД как источник данных для подсистемы планирования

1 отзывFavoriteLoadingВ закладки

Здравствуйте.

Задумал использовать общий макет СКД для получения одних и тех же данных (для планирования закупа). Например такие данные как остаток на начало текущего месяца, товары в пути, неликвидный товар, продажи прошлых 6 месяцев за каждый месяц отдельно.

Все это нужно выводить в виде дерева, в разрезе основных свойств характеристик. Основные свойства характеристик задаются в периодическом регистре сведений.

Отбирать нужно по подразделению и периоду. Когда выяснилось, что иногда отбирать нужно по складу, тут я встрял.

Здравствуйте. Задумал использовать общий макет СКД для получения одних и тех же данных (для планирования закупа). Например такие данные как остаток на начало текущего месяца, товары в пути, неликвидный товар, продажи прошлых 6 месяцев за каждый месяц отдельно. Все это нужно выводить в виде дерева, в разрезе основных свойств характеристик. Основные свойства характеристик задаются в периодическом регистре сведений. Отбирать нужно по подразделению и периоду. Когда выяснилось, что иногда отбирать нужно по складу, тут я встрял....

Далее
Страница 42 из 75« Первая...102030...4041424344...506070...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.