Вопрос-ответ

Программный вывод СКД с собственным макетом, пустые строки???

Отзывов (14)FavoriteLoadingВ закладки

Вывожу в ТД отчёт, всё хорошо, все данные вывелись, но почему пустые строки после шапки и перед итогом, макет рисовал сам, области выделены верно???

 

Пример:

В СКД нарисовал макет (рис 1) и привязал его к данным (рис 2), результат (рис 3).

Код вывода:

&НаКлиенте
Процедура Сформировать(Команда)
	СКД = Отчеты.ВедомостьЗамераОстатков.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");	
	Настройки = СКД.НастройкиПоУмолчанию;	
	Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных;
	
	МакетКомпоновки = Новый КомпоновщикМакетаКомпоновкиДанных;
	Макет = МакетКомпоновки.Выполнить(СКД,Настройки,Расшифровка);
	
	ПроцессорКомпоновки = новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(Макет);
	
	ПроцессорВывода = новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	
	ТД.Очистить();
	ТД.АвтоМасштаб = Истина;
	ТД.НижнийКолонтитул.Выводить = Истина;
	ТД.НижнийКолонтитул.ТекстСправа = "Страница [&НомерСтраницы] из [&СтраницВсего]";
	
	ПроцессорВывода.УстановитьДокумент(ТД);
	
	ПроцессорВывода.НачатьВывод();
	
	Пока Истина Цикл
    	ЭлементРезультата = ПроцессорКомпоновки.Следующий();
    	Если ЭлементРезультата= Неопределено Тогда
        	Прервать;
		Иначе						
        	ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);			
        КонецЕсли;
    КонецЦикла;
  
	ПроцессорВывода.ЗакончитьВывод();
	
КонецПроцедуры

 

Вывожу в ТД отчёт, всё хорошо, все данные вывелись, но почему пустые строки после шапки и перед итогом, макет рисовал сам, области выделены верно???   Пример: В СКД нарисовал макет (рис 1) и привязал его к данным (рис 2), результат (рис 3). Код вывода: &НаКлиенте Процедура Сформировать(Команда) СКД = Отчеты.ВедомостьЗамераОстатков.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); Настройки = СКД.НастройкиПоУмолчанию; Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных; МакетКомпоновки = Новый КомпоновщикМакетаКомпоновкиДанных; Макет = МакетКомпоновки.Выполнить(СКД,Настройки,Расшифровка); ПроцессорКомпоновки = новый ПроцессорКомпоновкиДанных; ПроцессорКомпоновки.Инициализировать(Макет); ПроцессорВывода = новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент; ТД.Очистить(); ТД.АвтоМасштаб = Истина; ТД.НижнийКолонтитул.Выводить = Истина; ТД.НижнийКолонтитул.ТекстСправа = "Страница [&НомерСтраницы] из [&СтраницВсего]"; ПроцессорВывода.УстановитьДокумент(ТД); ПроцессорВывода.НачатьВывод(); Пока Истина Цикл ЭлементРезультата = ПроцессорКомпоновки.Следующий(); Если ЭлементРезультата= Неопределено Тогда Прервать; Иначе ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата); КонецЕсли; КонецЦикла; ПроцессорВывода.ЗакончитьВывод(); КонецПроцедуры  ...

Далее

Обращение к ИсточникамДанных из других ИсточниковДанных

Отзывов (6)FavoriteLoadingВ закладки

Простой пример: есть простая таблица полученная очень сложным запросом, она состоит из 4х колонок.

  1. ТипПрибора
  2. Состояние
  3. ДатаИзменения
  4. Оператор
Есть еще 3 источника данных (Запросы) в которых хотелось бы обращаться к данной таблице это можно сделать в СКД?
И раз уж такой удачный пример ещё один вопрос результат отчёта должен иметь такую шапку:
Оператор Колонка1 ТипПрибора1 ТипПрибораN ТипПрибора5 Колонка2
    Состояние Состояние ДатаИзменеия Состояние ДатаИзменеия  Состояние
можно такое сделать в СКД?
Простой пример: есть простая таблица полученная очень сложным запросом, она состоит из 4х колонок. ТипПрибора Состояние ДатаИзменения Оператор Есть еще 3 источника данных (Запросы) в которых хотелось бы обращаться к данной таблице это можно сделать в СКД? И раз уж такой удачный пример ещё один вопрос результат отчёта должен иметь такую шапку: Оператор Колонка1 ТипПрибора1 ТипПрибораN… ТипПрибора5 Колонка2     Состояние Состояние ДатаИзменеия Состояние ДатаИзменеия  Состояние можно такое сделать в СКД? Перейти к...

Далее

Исключение неиспользуемых таблиц/пакетов из объединения.

Отзывов (6)FavoriteLoadingВ закладки

Есть задание на отчёт из более чем 100 колонок.
Суть отчёта показать что оператор делал по контрагенту т.е. набор колонок:

Оператор
Контрагент
ВведеноДокументовИзменений
ВведеноДокументовОтгрузки
...
...
СозданоЧегоНибудь

Причём Операторов 10-20, контрагентов 10 000 – 80 000

Информацию я получаю пакетами в запросе (в Временые таблицы), всего получается 14 пакетов, соответственно 14 ВременныхТаблиц в каждой таблице есть Колонки “Оператор”,”Контрагент” ну и набор колонок для вывода в отчёт.

Первая проблема которая возникает как это всё объединить. Т.е. к какой таблице подключить каждую из 14 ВременыхТаблиц полученных в пакетах.
Понятно что не одна из 14 таблиц не может быть опорной таблицей.

Есть задание на отчёт из более чем 100 колонок. Суть отчёта показать что оператор делал по контрагенту т.е. набор колонок: Оператор Контрагент ВведеноДокументовИзменений ВведеноДокументовОтгрузки ... ... СозданоЧегоНибудь Причём Операторов 10-20, контрагентов 10 000 – 80 000 Информацию я получаю пакетами в запросе (в Временые таблицы), всего получается 14 пакетов, соответственно 14 ВременныхТаблиц в каждой таблице есть Колонки “Оператор”,”Контрагент” ну и набор колонок для вывода в отчёт. Первая проблема которая возникает как это всё объединить. Т.е. к какой таблице подключить каждую из 14 ВременыхТаблиц полученных в пакетах. Понятно что не одна из 14 таблиц не может быть опорной таблицей....

Далее

Загрузка из SQL2000 и сравнение с таблицей 1С

Отзывов (4)FavoriteLoadingВ закладки

Добрый день задача стоит такая. Загрузить данные

с SQL 2000 и сравнить их с таблицей из 1с.

Данные из SQL получилось загрузить в таблицу

ДанныеSQL. C помощью СКД пытаюсь создать связь с

таблицей добавляю ее как объект и с запросом(

считывает с 1С данные). Но связка почему то не

получается и как вывести в результат данные же с SQL&

 

Добрый день задача стоит такая. Загрузить данные с SQL 2000 и сравнить их с таблицей из 1с. Данные из SQL получилось загрузить в таблицу ДанныеSQL. C помощью СКД пытаюсь создать связь с таблицей добавляю ее как объект и с запросом( считывает с 1С данные). Но связка почему то не получается и как вывести в результат данные же с SQL&   Перейти к...

Далее

1с 8.1 СКД Представление отсутствующего значения

Отзывов (8)FavoriteLoadingВ закладки

Строю запрос по номенклатуре, по нескольким регистрам. Отдельной колонкой вывожу разницу между значениями нескольких регистров. Как сделать так, что если в регистре значение по данной номенклатуре отсутствует, выводить в колонку 0, и соответственно адекватно  подсчитывать вычисляемые реквизит?

Строю запрос по номенклатуре, по нескольким регистрам. Отдельной колонкой вывожу разницу между значениями нескольких регистров. Как сделать так, что если в регистре значение по данной номенклатуре отсутствует, выводить в колонку 0, и соответственно адекватно  подсчитывать вычисляемые реквизит? Перейти к...

Далее

1С 8 СКД Программно установить уровень групировки

Отзывов (2)FavoriteLoadingВ закладки

Есть ли возможность в СКД программно выставить уровень групировки?

К примеру: Отчет выводит данные с тремя уровнями группировок. Но в основном нужно что бы открывалась 2 группировка. Есть ли какой еще нить метод свернуть группировку, кроме ручного?

Есть ли возможность в СКД программно выставить уровень групировки? К примеру: Отчет выводит данные с тремя уровнями группировок. Но в основном нужно что бы открывалась 2 группировка. Есть ли какой еще нить метод свернуть группировку, кроме ручного? Перейти к...

Далее
Страница 33 из 38« Первая...1020...3132333435...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.