Вопрос-ответ

Удаление строк из отчета на СКД без отражения в итогах.

Отзывов (3)FavoriteLoadingВ закладки

Имеется простейшая схема СКД.

Запрос отбирает строки расходных накладных (товар, количество, сумма) и выводит их в список.

Компоновка выводит на в верхнюю часть группы список накладных и итоговую сумму накладной как сумма строк, а в качестве строк вложенной группировки строки накладной.

Как мне убрать из отчета некоторые строки назовем их плохими, при этом итоговые суммы по группам не должны измениться.???

 

 

 

Если посмотреть на картинку мне надо чтобы строки где оборот менее 10 не отображались, но общий оборт как был 28 так и остался 28.

Имеется простейшая схема СКД. Запрос отбирает строки расходных накладных (товар, количество, сумма) и выводит их в список. Компоновка выводит на в верхнюю часть группы список накладных и итоговую сумму накладной как сумма строк, а в качестве строк вложенной группировки строки накладной. Как мне убрать из отчета некоторые строки назовем их плохими, при этом итоговые суммы по группам не должны измениться.???       Если посмотреть на картинку мне надо чтобы строки где оборот менее 10 не отображались, но общий оборт как был 28 так и остался 28. Перейти к...

Далее

СКД: Группировка по регистратору и полю-периоду

Отзывов (3)FavoriteLoadingВ закладки

Все дальнейшие примеры приведены для платформы 8.2.14.439 / Демонсрационная конфигурация УТ 11.0.4.5
Все сокращенные ссылки ведут в Google Docs (учетная запись не требуется)

Имеем самый простой запрос к виртуальной таблице “Остатков и Оборотов” регистра “ТоварыНаСкладах”.

Собственно схема компоновки: http://goo.gl/oIWhb
В схеме имеется поле – реквизит измерения “Склад”. Всем полям назначены корректные роли.
В настройках в группировках строк имеем группировку по номенклатуре

Ситуация 1:

Настройки: http://goo.gl/6vqwD

Добавляем вывод детальных записей (Поле Регистратор, Сортировка по регистратору).

В результате получаем корректные остатки по измерению номенклатуры, по детальным записям начальные и конечные
остатки, как и ожидалось “СКАЧУТ” – т.е. нарушается связь: начальный остаток записи равен конечному остатку предыдущей записи.

Все дальнейшие примеры приведены для платформы 8.2.14.439 / Демонсрационная конфигурация УТ 11.0.4.5 Все сокращенные ссылки ведут в Google Docs (учетная запись не требуется) Имеем самый простой запрос к виртуальной таблице “Остатков и Оборотов” регистра “ТоварыНаСкладах”. Собственно схема компоновки: http://goo.gl/oIWhb В схеме имеется поле – реквизит измерения “Склад”. Всем полям назначены корректные роли. В настройках в группировках строк имеем группировку по номенклатуре Ситуация 1: Настройки: http://goo.gl/6vqwD Добавляем вывод детальных записей (Поле Регистратор, Сортировка по регистратору). В результате получаем корректные остатки по измерению номенклатуры, по детальным записям начальные и конечные остатки, как и ожидалось “СКАЧУТ” – т.е. нарушается связь: начальный остаток записи равен конечному остатку предыдущей записи....

Далее

Разворачивание по горизонтали

Отзывов (5)FavoriteLoadingВ закладки

Господа, помогите, сам не справился

СКД разворачивает по горизонтали по измерениям, если есть ресуры.

Но у меня в схеме используются только измерения.

2 из них я хочу использовать в группировках, одну, номенклатуру разворачивать по вертикали, другую, дату по горизонтали. Остальные измерения используются в качестве детальных записей и отображать в колонках.

Не знаю как заставить СКД работать в таком режиме.

Господа, помогите, сам не справился СКД разворачивает по горизонтали по измерениям, если есть ресуры. Но у меня в схеме используются только измерения. 2 из них я хочу использовать в группировках, одну, номенклатуру разворачивать по вертикали, другую, дату по горизонтали. Остальные измерения используются в качестве детальных записей и отображать в колонках. Не знаю как заставить СКД работать в таком режиме. Перейти к...

Далее

Две таблицы с общей группировкой

Отзывов (2)FavoriteLoadingВ закладки

Нужно сформировать отчет следующего типа: первая таблица – обороты счета по дебету, вторая – обороты по кредиту. Колонки – первое субконто счета (номенклатура в данном случае), строки – корреспонденция счета (корсчет, корсубконто), реквизиты – сумма и количество.

По отдельности все формируется без проблем, но нужно сделать так, чтобы колонки обеих таблиц совпадали. Реально ли так вообще сделать?

Отчет

Форма сейчас:

Форма требуемая:

 

 

Нужно сформировать отчет следующего типа: первая таблица – обороты счета по дебету, вторая – обороты по кредиту. Колонки – первое субконто счета (номенклатура в данном случае), строки – корреспонденция счета (корсчет, корсубконто), реквизиты – сумма и количество. По отдельности все формируется без проблем, но нужно сделать так, чтобы колонки обеих таблиц совпадали. Реально ли так вообще сделать? Отчет Форма сейчас: Форма требуемая:     Перейти к...

Далее

Программный вывод СКД с собственным макетом, пустые строки???

Отзывов (14)FavoriteLoadingВ закладки

Вывожу в ТД отчёт, всё хорошо, все данные вывелись, но почему пустые строки после шапки и перед итогом, макет рисовал сам, области выделены верно???

 

Пример:

В СКД нарисовал макет (рис 1) и привязал его к данным (рис 2), результат (рис 3).

Код вывода:

&НаКлиенте
Процедура Сформировать(Команда)
	СКД = Отчеты.ВедомостьЗамераОстатков.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");	
	Настройки = СКД.НастройкиПоУмолчанию;	
	Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных;
	
	МакетКомпоновки = Новый КомпоновщикМакетаКомпоновкиДанных;
	Макет = МакетКомпоновки.Выполнить(СКД,Настройки,Расшифровка);
	
	ПроцессорКомпоновки = новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(Макет);
	
	ПроцессорВывода = новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	
	ТД.Очистить();
	ТД.АвтоМасштаб = Истина;
	ТД.НижнийКолонтитул.Выводить = Истина;
	ТД.НижнийКолонтитул.ТекстСправа = "Страница [&НомерСтраницы] из [&СтраницВсего]";
	
	ПроцессорВывода.УстановитьДокумент(ТД);
	
	ПроцессорВывода.НачатьВывод();
	
	Пока Истина Цикл
    	ЭлементРезультата = ПроцессорКомпоновки.Следующий();
    	Если ЭлементРезультата= Неопределено Тогда
        	Прервать;
		Иначе						
        	ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);			
        КонецЕсли;
    КонецЦикла;
  
	ПроцессорВывода.ЗакончитьВывод();
	
КонецПроцедуры

 

Вывожу в ТД отчёт, всё хорошо, все данные вывелись, но почему пустые строки после шапки и перед итогом, макет рисовал сам, области выделены верно???   Пример: В СКД нарисовал макет (рис 1) и привязал его к данным (рис 2), результат (рис 3). Код вывода: &НаКлиенте Процедура Сформировать(Команда) СКД = Отчеты.ВедомостьЗамераОстатков.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); Настройки = СКД.НастройкиПоУмолчанию; Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных; МакетКомпоновки = Новый КомпоновщикМакетаКомпоновкиДанных; Макет = МакетКомпоновки.Выполнить(СКД,Настройки,Расшифровка); ПроцессорКомпоновки = новый ПроцессорКомпоновкиДанных; ПроцессорКомпоновки.Инициализировать(Макет); ПроцессорВывода = новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент; ТД.Очистить(); ТД.АвтоМасштаб = Истина; ТД.НижнийКолонтитул.Выводить = Истина; ТД.НижнийКолонтитул.ТекстСправа = "Страница [&НомерСтраницы] из [&СтраницВсего]"; ПроцессорВывода.УстановитьДокумент(ТД); ПроцессорВывода.НачатьВывод(); Пока Истина Цикл ЭлементРезультата = ПроцессорКомпоновки.Следующий(); Если ЭлементРезультата= Неопределено Тогда Прервать; Иначе ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата); КонецЕсли; КонецЦикла; ПроцессорВывода.ЗакончитьВывод(); КонецПроцедуры  ...

Далее

Обращение к ИсточникамДанных из других ИсточниковДанных

Отзывов (6)FavoriteLoadingВ закладки

Простой пример: есть простая таблица полученная очень сложным запросом, она состоит из 4х колонок.

  1. ТипПрибора
  2. Состояние
  3. ДатаИзменения
  4. Оператор
Есть еще 3 источника данных (Запросы) в которых хотелось бы обращаться к данной таблице это можно сделать в СКД?
И раз уж такой удачный пример ещё один вопрос результат отчёта должен иметь такую шапку:
Оператор Колонка1 ТипПрибора1 ТипПрибораN ТипПрибора5 Колонка2
    Состояние Состояние ДатаИзменеия Состояние ДатаИзменеия  Состояние
можно такое сделать в СКД?
Простой пример: есть простая таблица полученная очень сложным запросом, она состоит из 4х колонок. ТипПрибора Состояние ДатаИзменения Оператор Есть еще 3 источника данных (Запросы) в которых хотелось бы обращаться к данной таблице это можно сделать в СКД? И раз уж такой удачный пример ещё один вопрос результат отчёта должен иметь такую шапку: Оператор Колонка1 ТипПрибора1 ТипПрибораN… ТипПрибора5 Колонка2     Состояние Состояние ДатаИзменеия Состояние ДатаИзменеия  Состояние можно такое сделать в СКД? Перейти к...

Далее
Страница 32 из 38« Первая...1020...3031323334...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.