Вопрос-ответ

СКД вывод данных за разные периоды

Отзывов (6)FavoriteLoadingВ закладки

Добрый день подскажите как можно сделать такую штуку на скд. Пользователь указывает период например, текущий месяц, а ему показывают данные за тот месяц который он выбрал(1 колонка ) + за предыдущий месяц(2 колонка). Пользователь всегда будет выбирать период месяц, т.к. интересуют данные только за 1 месяц. Просто можно сделать через обьединение запросов, а вот как задать второй период  парметром или еще както… И как будет более правильно сделать это одним запросом, через обьединить или соединить наборы даных в СКД?

Добрый день подскажите как можно сделать такую штуку на скд. Пользователь указывает период например, текущий месяц, а ему показывают данные за тот месяц который он выбрал(1 колонка ) + за предыдущий месяц(2 колонка). Пользователь всегда будет выбирать период месяц, т.к. интересуют данные только за 1 месяц. Просто можно сделать через обьединение запросов, а вот как задать второй период  парметром или еще както… И как будет более правильно сделать это одним запросом, через обьединить или соединить наборы даных в СКД? Перейти к...

Далее

В отчете написанном на СКД 1С 8.2 выскакивает пустая колонка. Ну никак не понимаю отчего она выскакивает.

Отзывов (2)FavoriteLoadingВ закладки

Значить опишу суть моего вопроса. Я создал отчет для 1С: УТ, написал его с использыванием механизма СКД, Отчет работает вроде бы нормально, но выскакивает пустая колонка в Группировке склад. В этой группировки 2 ресурса, если их развести в разные группировки то колонка пропадает, но надо что бы они выводились вместе, т.к. если группировки Склад будт 2 то отчет еще раз развернет мне детализацию по складам, а оно мне не надо.

Причем в базе нет склада с пустым именем, там все хорошо, это я проверил.

Вот так выглядит настройка таблицы в скд

Значить опишу суть моего вопроса. Я создал отчет для 1С: УТ, написал его с использыванием механизма СКД, Отчет работает вроде бы нормально, но выскакивает пустая колонка в Группировке склад. В этой группировки 2 ресурса, если их развести в разные группировки то колонка пропадает, но надо что бы они выводились вместе, т.к. если группировки Склад будт 2 то отчет еще раз развернет мне детализацию по складам, а оно мне не надо. Причем в базе нет склада с пустым именем, там все хорошо, это я проверил. Вот так выглядит настройка таблицы в скд...

Далее

Разворот итогов по месяцам vs Регистратор

1 отзывFavoriteLoadingВ закладки

Приветствую гуру СКД.

Вопрос покажется баяном, многие его задавали, но ответа я не нашёл.

Имеем проекты, которые оценены в некие суммы, по меревыполнения проекта стоимость проекта уменьшается.

Задача получить таблицу с оборотами и остатками по месяцам.

Запрос:

ВЫБРАТЬ РАЗРЕШЕННЫЕ
Проект.Ссылка КАК ПроектнаяДокументация,
Проект.Объект КАК НашОбъект,
Проект.Заказчик КАК Заказчик,
Проект.Договор КАК Договор,
Проект.Организация,
СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПроектнаяДокументация.Ссылка КАК СуммаРаботПроектнаяДокументация,
СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяРасход) КАК СуммаРабочаяРасход,
СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.Раздел,
СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяКонечныйОстаток) КАК СуммаРабочаяКонечныйОстаток,
СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяНачальныйОстаток) КАК СуммаРабочаяНачальныйОстаток,
СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПериодМесяц КАК я_ПериодМесяц,
СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.Объект КАК Объект,
СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяОборот) КАК СуммаРабочаяОборот,
СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПериодСекунда
ИЗ
РегистрНакопления.СуммаРаботПоПроектнойДокументации.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, Авто, , ) КАК СуммаРаботПоПроектнойДокументацииОстаткиИОбороты
ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ПроектнаяДокументация КАК Проект
ПО СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПроектнаяДокументация = Проект.Ссылка

Приветствую гуру СКД. Вопрос покажется баяном, многие его задавали, но ответа я не нашёл. Имеем проекты, которые оценены в некие суммы, по меревыполнения проекта стоимость проекта уменьшается. Задача получить таблицу с оборотами и остатками по месяцам. Запрос: ВЫБРАТЬ РАЗРЕШЕННЫЕ Проект.Ссылка КАК ПроектнаяДокументация, Проект.Объект КАК НашОбъект, Проект.Заказчик КАК Заказчик, Проект.Договор КАК Договор, Проект.Организация, СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПроектнаяДокументация.Ссылка КАК СуммаРаботПроектнаяДокументация, СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяРасход) КАК СуммаРабочаяРасход, СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.Раздел, СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяКонечныйОстаток) КАК СуммаРабочаяКонечныйОстаток, СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяНачальныйОстаток) КАК СуммаРабочаяНачальныйОстаток, СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПериодМесяц КАК я_ПериодМесяц, СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.Объект КАК Объект, СУММА(СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.СуммаРабочаяОборот) КАК СуммаРабочаяОборот, СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПериодСекунда ИЗ РегистрНакопления.СуммаРаботПоПроектнойДокументации.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, Авто, , ) КАК СуммаРаботПоПроектнойДокументацииОстаткиИОбороты ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ПроектнаяДокументация КАК Проект ПО СуммаРаботПоПроектнойДокументацииОстаткиИОбороты.ПроектнаяДокументация = Проект.Ссылка...

Далее

Как сохранить/восстановить настройки схемы и вариант схемы СКД?

Ваш отзывFavoriteLoadingВ закладки

Платформа 8.2 , обычное приложение. В отчете есть несколько схем СКД, на форме отчета в списке выбора пользователь сам выбирает нужную схему, помогите разобраться как сохранять/воостанавливать настройки  схемы вместе с вариантом отчета. Настройки сохраняю в РС.СохраненныеНастройки.   Проблема в том что я не понимаю как сохранить настройки СКД и значения реквизитов отчета вместе , получается только либо  первое либо второе.

код такой:

//Заполнение вариантов отчета

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
 Варианты = Новый СписокЗначений;
  Макеты = ЭтотОбъект.Метаданные().Макеты;
 Для Каждого Схема ИЗ Макеты Цикл
  Варианты.Добавить(Схема.Имя,Схема.Синоним);
 КонецЦикла;
 ЭлементыФормы.СписокВариантов.СписокВыбора = Варианты;
 КонецПроцедуры

//выбор варианта отчета

Процедура СписокВариантовПриИзменении(Элемент)
  СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет(Элемент.Значение);
  КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
  Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
  КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
КонецПроцедуры 

Платформа 8.2 , обычное приложение. В отчете есть несколько схем СКД, на форме отчета в списке выбора пользователь сам выбирает нужную схему, помогите разобраться как сохранять/воостанавливать настройки  схемы вместе с вариантом отчета. Настройки сохраняю в РС.СохраненныеНастройки.   Проблема в том что я не понимаю как сохранить настройки СКД и значения реквизитов отчета вместе , получается только либо  первое либо второе. код такой: //Заполнение вариантов отчета Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)  Варианты = Новый СписокЗначений;   Макеты = ЭтотОбъект.Метаданные().Макеты;  Для Каждого Схема ИЗ Макеты Цикл   Варианты.Добавить(Схема.Имя,Схема.Синоним);  КонецЦикла;  ЭлементыФормы.СписокВариантов.СписокВыбора = Варианты;  КонецПроцедуры //выбор варианта отчета Процедура СписокВариантовПриИзменении(Элемент)   СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет(Элемент.Значение);   КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));   Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;   КомпоновщикНастроек.ЗагрузитьНастройки(Настройки); КонецПроцедуры ...

Далее

Разрыв страницы в макете

Отзывов (3)FavoriteLoadingВ закладки

Необходимо разработать примерно такую печатную форму:

—————- —————- —————- —————-

Заявление

Я,  <Физлицо> согласен на …

Подпись, дата

—————- —————- —————- —————-

И с новой страницы следующий Физлицо

 

В СКД создал макет, а заставить каждого следующего печататся с новой страницы пока не получается. Варианты Галка НачалоСтраницы и Таблица > Настройка печати > Вставить разрыв страницы результатов не дали!!

Спасибо всем заранее

Необходимо разработать примерно такую печатную форму: —————- —————- —————- —————- Заявление Я,  <Физлицо> согласен на … Подпись, дата —————- —————- —————- —————- И с новой страницы следующий Физлицо   В СКД создал макет, а заставить каждого следующего печататся с новой страницы пока не получается. Варианты Галка НачалоСтраницы и Таблица > Настройка печати > Вставить разрыв страницы результатов не дали!! Спасибо всем заранее Перейти к...

Далее

Отчет по продажам с разворотом по типам цен (СКД).

1 отзывFavoriteLoadingВ закладки

Подскажите пожалуйста, делаю отчет по регистру ПродажиОбороты с разворотом по типам цен. (Конфа Ут 10)

Нужно вывести вот такого плана отчет

ВЫБРАТЬ
ПродажиОбороты.Номенклатура,
ПродажиОбороты.КоличествоОборот,
ПродажиОбороты.СтоимостьОборот,
ПродажиОбороты.ДокументПродажи.КассаККМ,
ЦеныНоменклатурыСрезПоследних.ТипЦен,
ЦеныНоменклатурыСрезПоследних.Цена
ИЗ
РегистрНакопления.Продажи.Обороты КАК ПродажиОбороты
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних({(&КонецПериода)}, ) КАК ЦеныНоменклатурыСрезПоследних
ПО ПродажиОбороты.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура
И ПродажиОбороты.ХарактеристикаНоменклатуры = ЦеныНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры

В настройках делаю таблицу

Строки

– Номенклатура

Колонки

– ДетальныеЗаписи (Выбранные поля – КоличествоОборот, СтоимостьОборот)

-ТипЦен(Выбранные поля – ТипЦены,Цена)

Все выводится но значения КоличествоОборот и СтоимостьОборот в детальных записях умножены на количество типов цен.

Подскажите пожалуйста как исправить.

 

 

 

Подскажите пожалуйста, делаю отчет по регистру ПродажиОбороты с разворотом по типам цен. (Конфа Ут 10) Нужно вывести вот такого плана отчет ВЫБРАТЬ ПродажиОбороты.Номенклатура, ПродажиОбороты.КоличествоОборот, ПродажиОбороты.СтоимостьОборот, ПродажиОбороты.ДокументПродажи.КассаККМ, ЦеныНоменклатурыСрезПоследних.ТипЦен, ЦеныНоменклатурыСрезПоследних.Цена ИЗ РегистрНакопления.Продажи.Обороты КАК ПродажиОбороты ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних({(&КонецПериода)}, ) КАК ЦеныНоменклатурыСрезПоследних ПО ПродажиОбороты.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура И ПродажиОбороты.ХарактеристикаНоменклатуры = ЦеныНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры В настройках делаю таблицу Строки – Номенклатура Колонки – ДетальныеЗаписи (Выбранные поля – КоличествоОборот, СтоимостьОборот) -ТипЦен(Выбранные поля – ТипЦены,Цена) Все выводится но значения КоличествоОборот и СтоимостьОборот в детальных записях умножены на количество типов цен. Подскажите пожалуйста как исправить.       Перейти к...

Далее
Страница 30 из 49« Первая...1020...2829303132...40...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.