Вопрос-ответ

Проблема с перепроведением документа.Help!!

Ваш отзывFavoriteLoadingВ закладки

Документ ПКО второй раз не проводится, так мне и надо, а как сделать так, чтобы можно было ПЕРЕПРОВЕСТИ существующий ПКО????(платформа 8.2)

Я создаю на основании документа ОтгрузкаТоваровСоСкдлада документ ПриходныйКассовыйОрдер.

вот код:
ОтгрузаТовараСоСклада = (ТипЗнч(Основание)=Тип(“ДокументСсылка.ОтгрузаТовараСоСклада”)); ///

Если ОтгрузаТовараСоСклада Тогда ///
ПодчиненныйДокумент = Документы.ПриходныйКассовыйОрдер.НайтиПоРеквизиту(“Основание”, Основание); ///
Если ЗначениеЗаполнено(ПодчиненныйДокумент) Тогда
Отказ = Истина;
Запись = Истина;
//Проведение = Истина ;
КонецЕсли;
КонецЕсли;

Помогите пожалуйста .

Документ ПКО второй раз не проводится, так мне и надо, а как сделать так, чтобы можно было ПЕРЕПРОВЕСТИ существующий ПКО????(платформа 8.2) Я создаю на основании документа ОтгрузкаТоваровСоСкдлада документ ПриходныйКассовыйОрдер. вот код: ОтгрузаТовараСоСклада = (ТипЗнч(Основание)=Тип(“ДокументСсылка.ОтгрузаТовараСоСклада”)); /// Если ОтгрузаТовараСоСклада Тогда /// ПодчиненныйДокумент = Документы.ПриходныйКассовыйОрдер.НайтиПоРеквизиту(“Основание”, Основание); /// Если ЗначениеЗаполнено(ПодчиненныйДокумент) Тогда Отказ = Истина; Запись = Истина; //Проведение = Истина ; КонецЕсли; КонецЕсли; Помогите пожалуйста . Перейти к...

Далее

Шапки в отчете.как переименовать?

Отзывов (2)FavoriteLoadingВ закладки

доброго времени суток! у меня проблема: не могу привети в нормальный вид шапки например “баллы”(а не как на скриншоте) в отчете

в объединение/псевдонимы пишет ошибку,  как  переименовать табличную часть  ?

 

доброго времени суток! у меня проблема: не могу привети в нормальный вид шапки например “баллы”(а не как на скриншоте) в отчете в объединение/псевдонимы пишет ошибку,  как  переименовать табличную часть  ?   Перейти к...

Далее

Дублирование в СКД.HELP!

Отзывов (3)FavoriteLoadingВ закладки

Добрый день!у меня есть 2 похожих отчета
Список студентов на бюджетной основе, сумма оплаты (по группам) и
Список студентов, зачисленных в колледж. в 1 отчете у меня почему то дублируются люди во все группы.
в отчеет 2 все нормально(но там надо еще добавить кое-что ) но я уже несколько раз переделала безрезультатно. подскажи в чем проблема ?

Добрый день!у меня есть 2 похожих отчета Список студентов на бюджетной основе, сумма оплаты (по группам) и Список студентов, зачисленных в колледж. в 1 отчете у меня почему то дублируются люди во все группы. в отчеет 2 все нормально(но там надо еще добавить кое-что ) но я уже несколько раз переделала безрезультатно. подскажи в чем проблема ? Перейти к...

Далее

Группировка по дате

Ваш отзывFavoriteLoadingВ закладки

Нужно выбрать первые документы из введенных на основании Документа П.

 

пишу в схеме:

 

ВЫБРАТЬ
РН_Претензия.ДокументОснование,
МИНИМУМ(РН_Претензия.Дата) КАК Дата
ПОМЕСТИТЬ ИсходящиеСрезПервых
ИЗ
Документ.РН_Претензия КАК РН_Претензия
ГДЕ
РН_Претензия.ВидОперации = ЗНАЧЕНИЕ(Перечисление.РН_ВидыОперацийПретензия.Исходящая)
И РН_Претензия.ДокументОснование <> ЗНАЧЕНИЕ(Документ.РН_Претензия.ПустаяСсылка)
И РН_Претензия.ДокументОснование.ВидОперации = &ВидОперации
И РН_Претензия.Проведен = ИСТИНА
СГРУППИРОВАТЬ ПО
РН_Претензия.ДокументОснование
;
////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
РН_Претензия.Ссылка КАК Ссылка,
ЕСТЬNULL(ИсходящиеСрезПервых.Дата, ДАТАВРЕМЯ(1, 1, 1, 0, 0, 0)) КАК ПеревыставлениеФакт1,
Регистр.ПретензияИЗ
Регистр КАК Регистр
ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РН_Претензия КАК РН_Претензия
ВНУТРЕННЕЕ СОЕДИНЕНИЕ ИсходящиеСрезПервых КАК ИсходящиеСрезПервых
ПО РН_Претензия.Дата = ИсходящиеСрезПервых.Дата
ПО Регистр.Претензия = РН_Претензия.ДокументОснование

 

СКД все обрезает и формирует следующий запрос:

Нужно выбрать первые документы из введенных на основании Документа П.   пишу в схеме:   ВЫБРАТЬ РН_Претензия.ДокументОснование, МИНИМУМ(РН_Претензия.Дата) КАК Дата ПОМЕСТИТЬ ИсходящиеСрезПервых ИЗ Документ.РН_Претензия КАК РН_Претензия ГДЕ РН_Претензия.ВидОперации = ЗНАЧЕНИЕ(Перечисление.РН_ВидыОперацийПретензия.Исходящая) И РН_Претензия.ДокументОснование <> ЗНАЧЕНИЕ(Документ.РН_Претензия.ПустаяСсылка) И РН_Претензия.ДокументОснование.ВидОперации = &ВидОперации И РН_Претензия.Проведен = ИСТИНА СГРУППИРОВАТЬ ПО РН_Претензия.ДокументОснование ; //////////////////////////////////////////////////////////////////////////////// ВЫБРАТЬ РН_Претензия.Ссылка КАК Ссылка, ЕСТЬNULL(ИсходящиеСрезПервых.Дата, ДАТАВРЕМЯ(1, 1, 1, 0, 0, 0)) КАК ПеревыставлениеФакт1, Регистр.ПретензияИЗ Регистр КАК Регистр ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РН_Претензия КАК РН_Претензия ВНУТРЕННЕЕ СОЕДИНЕНИЕ ИсходящиеСрезПервых КАК ИсходящиеСрезПервых ПО РН_Претензия.Дата = ИсходящиеСрезПервых.Дата ПО Регистр.Претензия = РН_Претензия.ДокументОснование   СКД все обрезает и формирует следующий запрос:...

Далее

Вопрос. СКД. Свернуть по группировкам

1 отзывFavoriteLoadingВ закладки

Добрый день.

Есть отчет на скд. Состоит он из 3-х таблиц.

Как сделать так чтобы после формирования отчета таблица 2 была свернута до 1-го уровня группировок?

Добрый день. Есть отчет на скд. Состоит он из 3-х таблиц. Как сделать так чтобы после формирования отчета таблица 2 была свернута до 1-го уровня группировок? Перейти к...

Далее
Страница 21 из 38« Первая...10...1920212223...30...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.