Вопрос-ответ

Отчет по продажам с разворотом по типам цен (СКД).

1 отзывFavoriteLoadingВ закладки

Подскажите пожалуйста, делаю отчет по регистру ПродажиОбороты с разворотом по типам цен. (Конфа Ут 10)

Нужно вывести вот такого плана отчет

ВЫБРАТЬ
ПродажиОбороты.Номенклатура,
ПродажиОбороты.КоличествоОборот,
ПродажиОбороты.СтоимостьОборот,
ПродажиОбороты.ДокументПродажи.КассаККМ,
ЦеныНоменклатурыСрезПоследних.ТипЦен,
ЦеныНоменклатурыСрезПоследних.Цена
ИЗ
РегистрНакопления.Продажи.Обороты КАК ПродажиОбороты
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних({(&КонецПериода)}, ) КАК ЦеныНоменклатурыСрезПоследних
ПО ПродажиОбороты.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура
И ПродажиОбороты.ХарактеристикаНоменклатуры = ЦеныНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры

В настройках делаю таблицу

Строки

– Номенклатура

Колонки

– ДетальныеЗаписи (Выбранные поля – КоличествоОборот, СтоимостьОборот)

-ТипЦен(Выбранные поля – ТипЦены,Цена)

Все выводится но значения КоличествоОборот и СтоимостьОборот в детальных записях умножены на количество типов цен.

Подскажите пожалуйста как исправить.

 

 

 

Подскажите пожалуйста, делаю отчет по регистру ПродажиОбороты с разворотом по типам цен. (Конфа Ут 10) Нужно вывести вот такого плана отчет ВЫБРАТЬ ПродажиОбороты.Номенклатура, ПродажиОбороты.КоличествоОборот, ПродажиОбороты.СтоимостьОборот, ПродажиОбороты.ДокументПродажи.КассаККМ, ЦеныНоменклатурыСрезПоследних.ТипЦен, ЦеныНоменклатурыСрезПоследних.Цена ИЗ РегистрНакопления.Продажи.Обороты КАК ПродажиОбороты ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних({(&КонецПериода)}, ) КАК ЦеныНоменклатурыСрезПоследних ПО ПродажиОбороты.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура И ПродажиОбороты.ХарактеристикаНоменклатуры = ЦеныНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры В настройках делаю таблицу Строки – Номенклатура Колонки – ДетальныеЗаписи (Выбранные поля – КоличествоОборот, СтоимостьОборот) -ТипЦен(Выбранные поля – ТипЦены,Цена) Все выводится но значения КоличествоОборот и СтоимостьОборот в детальных записях умножены на количество типов цен. Подскажите пожалуйста как исправить.       Перейти к...

Далее

Настройка для свертки колонок вертикальных группировок СКД

Отзывов (2)FavoriteLoadingВ закладки

Подскажите, какую нужно указать настройку, чтоб сворачивались вертикальные колонки СКД и чтоб можно было зафиксировать определенное количество колонок слева.

Подскажите, какую нужно указать настройку, чтоб сворачивались вертикальные колонки СКД и чтоб можно было зафиксировать определенное количество колонок слева. Перейти к...

Далее

Вывод колонок таблицы, если не было движений

1 отзывFavoriteLoadingВ закладки

Получаю в запросе приход, расход, нач. остаток и кон. остаток. Вывожу в таблицу, колонки – вид операции. Для каждого вида операции нужен приход и расход, остатки нужны только общие. Настроила выводимые поля, все ок. Теперь проблема – если по данному виду операции только остатки, без прихода/расхода, то этот вид операции выводится отдельной колонкой, а мне надо, чтобы не выводился.

Как бы это сделать?

Нач. ост          Вид опер. 1          Вид опер. 2      Вид опер. 3               Кон.ост

Получаю в запросе приход, расход, нач. остаток и кон. остаток. Вывожу в таблицу, колонки – вид операции. Для каждого вида операции нужен приход и расход, остатки нужны только общие. Настроила выводимые поля, все ок. Теперь проблема – если по данному виду операции только остатки, без прихода/расхода, то этот вид операции выводится отдельной колонкой, а мне надо, чтобы не выводился. Как бы это сделать? Нач. ост          Вид опер. 1          Вид опер. 2      Вид опер. 3               Кон.ост...

Далее

СКД. Группировка полей строкового типа.

1 отзывFavoriteLoadingВ закладки

Добрый день.

У меня есть регистр сведений “Дольщики”:

Измерения – Сделка (Справочник), Номер(Число)

Ресурс – Дольщик(Строка)

По одной сделке может быть несколько дольщиков и хотелось бы получить отчет вот такого вида:

Сделка – Дольщики

СД0001 – Иванов, Петров, Сидоров

СД0002 – Петров

т.е сгруппировать поля Дольщик конкатенацией.

Реализуемо ли это средствами СКД, без лишних циклов и пр.

Спасибо.

Добрый день. У меня есть регистр сведений “Дольщики”: Измерения – Сделка (Справочник), Номер(Число) Ресурс – Дольщик(Строка) По одной сделке может быть несколько дольщиков и хотелось бы получить отчет вот такого вида: Сделка – Дольщики СД0001 – Иванов, Петров, Сидоров СД0002 – Петров т.е сгруппировать поля Дольщик конкатенацией. Реализуемо ли это средствами СКД, без лишних циклов и пр. Спасибо. Перейти к...

Далее

СКД форматирование заголовка поля

Отзывов (2)FavoriteLoadingВ закладки

Долгое время не могу справиться с проблемой. Как отформатировать заголовок поля независимо от форматирования самого поля. Например, хочу чтобы в шапке таблицы наименования колонок центрировались, а сами колонки выравнивались справа или слева или вообще  хочу названия колонок разместить вертикально.  При манипуляциях с разделом “Оформление” поля в наборе данных формат распространяется и на само значение и на заголовок. Тривиальная вроде проблема, но времени убито не мало…….Пробовал отформатировать макетами, но не нашел как добавить макет заголовка поля…..все что угодно можно, а заголовок нельзя, или искал не там.   Условное оформление в настройках так же положительного результата не дают. Разрабатывать целиком макет оформления для всего отчета, как-то не очень хочется.  Сделал первые попытки, но то же еще не во всем разобрался. Перерыл Интернет, были посты с такой проблемой, но без решения.  Может кто-то победил……поделитесь! Спасибо.

Долгое время не могу справиться с проблемой. Как отформатировать заголовок поля независимо от форматирования самого поля. Например, хочу чтобы в шапке таблицы наименования колонок центрировались, а сами колонки выравнивались справа или слева или вообще  хочу названия колонок разместить вертикально.  При манипуляциях с разделом “Оформление” поля в наборе данных формат распространяется и на само значение и на заголовок. Тривиальная вроде проблема, но времени убито не мало…….Пробовал отформатировать макетами, но не нашел как добавить макет заголовка поля…..все что угодно можно, а заголовок нельзя, или искал не там.   Условное оформление в настройках так же положительного результата не дают. Разрабатывать целиком макет оформления для всего отчета, как-то не очень хочется.  Сделал первые попытки, но то же еще не во всем разобрался. Перерыл Интернет, были посты с такой проблемой, но без решения.  Может кто-то победил……поделитесь! Спасибо. Перейти к...

Далее

Подскажите пожалуйста.Делаю отчет в СКД.Создала 2 варианта отчета.на форму вывела поле выбора варианта отчета,но почему то у меня не показываются варианты отчетов.

Отзывов (2)FavoriteLoadingВ закладки

Процедура ПриОткрытии()

    Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    Для каждого вариант из макет.ВариантыНастроек Цикл
        ЭлементыФормы.Варианты.СписокВыбора.Добавить(вариант.Представление);
    КонецЦикла;
    Варианты = ЭлементыФормы.Варианты.СписокВыбора[0].значение;

КонецПроцедуры

Процедура ВариантыПриИзменении(Элемент)
     Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    настройки=ОпределитьНастройки(макет, элемент.значение);
    КомпоновщикНастроек.ЗагрузитьНастройки(настройки);
    ЭлементыФормы.Результат.Очистить();
    СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки);

КонецПроцедуры
 Функция ОпределитьНастройки(Макет, представлениеМакета)
Для каждого вариант из макет.ВариантыНастроек Цикл
        если вариант.Представление=представлениеМакета тогда
            настройки=вариант.настройки;
        КонецЕсли;
    КонецЦикла;
Возврат настройки;
КонецФункции
Процедура ПриОткрытии() Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); Для каждого вариант из макет.ВариантыНастроек Цикл ЭлементыФормы.Варианты.СписокВыбора.Добавить(вариант.Представление); КонецЦикла; Варианты = ЭлементыФормы.Варианты.СписокВыбора[0].значение; КонецПроцедуры Процедура ВариантыПриИзменении(Элемент) Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); настройки=ОпределитьНастройки(макет, элемент.значение); КомпоновщикНастроек.ЗагрузитьНастройки(настройки); ЭлементыФормы.Результат.Очистить(); СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки); КонецПроцедуры Функция ОпределитьНастройки(Макет, представлениеМакета) Для каждого вариант из макет.ВариантыНастроек Цикл если вариант.Представление=представлениеМакета тогда настройки=вариант.настройки; КонецЕсли; КонецЦикла; Возврат настройки; КонецФункции Перейти к...

Далее
Страница 20 из 38« Первая...10...1819202122...30...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.