Платформа 8.2 , обычное приложение. В отчете есть несколько схем СКД, на форме отчета в списке выбора пользователь сам выбирает нужную схему, помогите разобраться как сохранять/воостанавливать настройки  схемы вместе с вариантом отчета. Настройки сохраняю в РС.СохраненныеНастройки.   Проблема в том что я не понимаю как сохранить настройки СКД и значения реквизитов отчета вместе , получается только либо  первое либо второе.

код такой:

//Заполнение вариантов отчета

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
 Варианты = Новый СписокЗначений;
  Макеты = ЭтотОбъект.Метаданные().Макеты;
 Для Каждого Схема ИЗ Макеты Цикл
  Варианты.Добавить(Схема.Имя,Схема.Синоним);
 КонецЦикла;
 ЭлементыФормы.СписокВариантов.СписокВыбора = Варианты;
 КонецПроцедуры

//выбор варианта отчета

Процедура СписокВариантовПриИзменении(Элемент)
  СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет(Элемент.Значение);
  КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
  Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
  КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
КонецПроцедуры 

Платформа 8.2 , обычное приложение. В отчете есть несколько схем СКД, на форме отчета в списке выбора пользователь сам выбирает нужную схему, помогите разобраться как сохранять/воостанавливать настройки  схемы вместе с вариантом отчета. Настройки сохраняю в РС.СохраненныеНастройки.   Проблема в том что я не понимаю как сохранить настройки СКД и значения реквизитов отчета вместе , получается только либо  первое либо второе. код такой: //Заполнение вариантов отчета Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)  Варианты = Новый СписокЗначений;   Макеты = ЭтотОбъект.Метаданные().Макеты;  Для Каждого Схема ИЗ Макеты Цикл   Варианты.Добавить(Схема.Имя,Схема.Синоним);  КонецЦикла;  ЭлементыФормы.СписокВариантов.СписокВыбора = Варианты;  КонецПроцедуры //выбор варианта отчета Процедура СписокВариантовПриИзменении(Элемент)   СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет(Элемент.Значение);   КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));   Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;   КомпоновщикНастроек.ЗагрузитьНастройки(Настройки); КонецПроцедуры ...