Как создать параметризированый заголовок поля таблицы

Отзывов (8)FavoriteLoadingВ закладки

Добрый день.

Нужно в  шапке таблицы в назвнии полей отражать информацию с произвольными параметрами например :

Остатки на &ТекущаяДата :

Можно это сделать и если да то как ?

Второй вопрос – производный от этого : Как сделать парамеризированный заголовок отчета  ?

 

 

 

 

 

 

 

 

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

8 Коммент.

  1. (1) У меня нет макета в этом отчете. Но даже если применять макет как передать параметр в поле макета ?

    • Описываете в макете в ячейке параметр через метод заполния “Параметр” или “Шаблон”. Дальше он появится в параметрах создваемой области. А его значение уже можно выбрать из параметров СКД.
      На скрине есть схема как это делается – http://screencast.com/t/qC4bgXxmqn

  2. (to Головаченко Дима)
    Спасибо за пример.
    А можно узнать как и в какой момент заполнять параметр в данной области ?
    Я знаю только способ
    в момент програмного вывода процессора компоновки данных :

    ПроцессорВывода.НачатьВывод();
    Пока Истина Цикл
    ЭлементРезультата = ПроцессорКомпоновкиДанных.Следующий();
    Если ЭлементРезультата = Неопределено Тогда
    Прервать;
    КонецЕсли;

    ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
    Если ЭлементРезультата.ЗначенияПараметров.Количество() = 0 Тогда
    Продолжить;
    КонецЕсли;

    Для Каждого ЭлементПараметра Из ЭлементРезультата.ЗначенияПараметров Цикл
    Если ТипЗнч(ЭлементПараметра.Значение) = Тип(“ИдентификаторРасшифровкиКомпоновкиДанных”) Тогда
    Поля = ДанныеРасшифровки.Элементы[ЭлементПараметра.Значение].ПолучитьПоля();
    Для Каждого Поле Из Поля Цикл
    Если Поле.Поле = “ВыгруженВЕГАИС” Тогда
    ВывестиИконкуВПолеСКД (“ВыгруженВЕГАИС”, Поле, ИконкаЕГАИС);
    ИначеЕсли Поле.Поле = “СмешанныйТовар” Тогда
    ВывестиИконкуВПолеСКД (“СмешанныйТовар”, Поле, ИконкаСмешанныйТовар);
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    онецЦикла;
    ПроцессорВывода.ЗакончитьВывод();

    • Значения параметров берутся из параметров данных КомпоновщикаНастроек.
      Овет – когда задаете параметры в КомпоновщикНастроек.
      Тот пример что у вас – это контролируемый вывод СКД. В принципе тут можно отловить (отладчиком) вывод заголовка и поменять значение.

  3. Можно и без макета, но без программизма никак:
    перед компоновкой результата получаете значение параметра &Период
    затем переобределяете свойство заголовок у поля
    КомпоновщикНастроек.Настройки.ВыбранныеПоля[ИндексПоля].Заголовок
    – может соврал, но суть в том что надо изменять примененные настройки СКД

  4. (to Головаченко Дима)

    А как правильно устанавливать менять параметры в в компоновщике настроек ?
    Где можно посмотреть правильные примеры ?
    Ато приходтися тыкаться наугад в отладчике.

    Я умею устанавливать параметры и отборы, а хочется управлять полями загололовками полей.

Оставить комментарий

RSSКомментарии в RSS

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.