Посты от 2013

Пост-релиз. Конференция INFOSTART EVENT EVOLUTION 2013.

Ваш отзывFavoriteLoadingВ закладки

23 и 24 мая 2013 года в Концертном зале «Колизей» на Невском, 100 в Санкт-Петербурге прошла крупнейшая конференция по управлению проектами и профессиональной разработке на платформе 1С:Предприятие – Infostart Event Evolution 2013.

 

Infostart Event Evolution – вторая конференция профессионального сообщества по автоматизации учета и управления на предприятии – Infostart.ru, самого многочисленного профессионального сообщества Рунета – более 350 000 пользователей! Первое мероприятие  состоялось в ноябре 2012 года и прошло с большим успехом, собрав в Петербурге более 500 специалистов со всей России и стран ближнего зарубежья.

 

23 и 24 мая 2013 года в Концертном зале «Колизей» на Невском, 100 в Санкт-Петербурге прошла крупнейшая конференция по управлению проектами и профессиональной разработке на платформе 1С:Предприятие – Infostart Event Evolution 2013.   Infostart Event Evolution – вторая конференция профессионального сообщества по автоматизации учета и управления на предприятии – Infostart.ru, самого многочисленного профессионального сообщества Рунета – более 350 000 пользователей! Первое мероприятие  состоялось в ноябре 2012 года и прошло с большим успехом, собрав в Петербурге более 500 специалистов со всей России и стран ближнего зарубежья.  ...

Далее

Как получить ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений через V82.ComConnector?

Отзывов (3)FavoriteLoadingВ закладки

Добрый день!  Есть необходимость подключиться к соседней базе, выполнить в ней СКД-отчет, получить результат в виде таблицы значений. Код, примерно, как ниже. Не могу сообразить, как правильно записать в последней строке параметр Тип(“ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений”), чтобы это был Com объект соседней базы. Подскажите, кто знает.

 

v8 = Новый COMОбъект("V82.ComConnector");
...
Соединение = V8.Connect(СтрокаПодключения);

Отчет = Соединение.Отчеты.Отчет.Создать();

Схема = Отчет.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");

Настройки = Схема.НастройкиПоУмолчанию;

Компоновщик = Соединение.NewObject("КомпоновщикМакетаКомпоновкиДанных");

Макет = Компоновщик.Выполнить(Схема, Настройки,,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));

...
Добрый день!  Есть необходимость подключиться к соседней базе, выполнить в ней СКД-отчет, получить результат в виде таблицы значений. Код, примерно, как ниже. Не могу сообразить, как правильно записать в последней строке параметр Тип(“ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений”), чтобы это был Com объект соседней базы. Подскажите, кто знает.   v8 = Новый COMОбъект("V82.ComConnector"); ... Соединение = V8.Connect(СтрокаПодключения); Отчет = Соединение.Отчеты.Отчет.Создать(); Схема = Отчет.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); Настройки = Схема.НастройкиПоУмолчанию; Компоновщик = Соединение.NewObject("КомпоновщикМакетаКомпоновкиДанных"); Макет = Компоновщик.Выполнить(Схема, Настройки,,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений")); ... Перейти к...

Далее

Как при помощи СКД сделать табличную часть документа в строку?

Отзывов (2)FavoriteLoadingВ закладки

У документа есть табличная часть.
Нужно вывести отчет  из колонок:
СсылкаДокумента, Строка1 (Тип строка)

Строка1 – Это перечень значений колонки табличной части документа

Как при помощи СКД сделать табличную часть документа в строку?

У документа есть табличная часть. Нужно вывести отчет  из колонок: СсылкаДокумента, Строка1 (Тип строка) Строка1 – Это перечень значений колонки табличной части документа Как при помощи СКД сделать табличную часть документа в строку? Перейти к...

Далее

Как посчитать дельту

Отзывов (5)FavoriteLoadingВ закладки

Формирую отчет по закупочным ценам и как определить дельту между закупочными цена, как показано на рисунке?

 

 

 

Формирую отчет по закупочным ценам и как определить дельту между закупочными цена, как показано на рисунке?       Перейти к...

Далее

Получаю неправильные настройки для СКД при использовании нескольких макетов СКД в одном отчете

Ваш отзывFavoriteLoadingВ закладки

В форме в процедуре ПриИзмененииВариатыСКД

Упрощённо:

Если Отчет.ВариатыСКД = 1 Тогда

СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Первый”);

Иначе

СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Второй”);

КонецЕсли;

URLКомпоновки = ПоместитьВоВременноеХранилище(СКД);
Отчет.КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(URLКомпоновки));
Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(СКД.НастройкиПоУмолчанию);
Отчет.КомпоновщикНастроек.Восстановить(СпособВосстановленияНастроекКомпоновкиДанных.Полное);

В модуле в Процедуре ПриКомпоновкеРезультата

:

Если ЭтотОбъект.ВариатыСКД = 1 Тогда

СКД = ЭтотОбъект.ПолучитьМакет(“Первый”);

Иначе

СКД = ЭтотОбъект.ПолучитьМакет(“Второй”);

КонецЕсли;

НастройкиСКД = ЭтотОбъект.КомпоновщикНастроек.ПолучитьНастройки();

Смотрю в отладчике значение НастройкиСКД.ДоступныеПоляДополнительныхОтборов – выдаёт список отборов из другого макета СКД.

А если заменить в модуле НастройкиСКД на

НастройкиСКД = СКД.НастройкиПоУмолчанию;

тогда НастройкиСКД.ДоступныеПоляДополнительныхОтборов выдаёт правильный список отборов,   но,  конечно с значениями по умолчанию.

В форме в процедуре ПриИзмененииВариатыСКД Упрощённо: Если Отчет.ВариатыСКД = 1 Тогда СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Первый”); Иначе СКД = РеквизитФормыВЗначение(“Отчет”).ПолучитьМакет(“Второй”); КонецЕсли; URLКомпоновки = ПоместитьВоВременноеХранилище(СКД); Отчет.КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(URLКомпоновки)); Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(СКД.НастройкиПоУмолчанию); Отчет.КомпоновщикНастроек.Восстановить(СпособВосстановленияНастроекКомпоновкиДанных.Полное); В модуле в Процедуре ПриКомпоновкеРезультата … : Если ЭтотОбъект.ВариатыСКД = 1 Тогда СКД = ЭтотОбъект.ПолучитьМакет(“Первый”); Иначе СКД = ЭтотОбъект.ПолучитьМакет(“Второй”); КонецЕсли; НастройкиСКД = ЭтотОбъект.КомпоновщикНастроек.ПолучитьНастройки(); … Смотрю в отладчике значение НастройкиСКД.ДоступныеПоляДополнительныхОтборов – выдаёт список отборов из другого макета СКД. А если заменить в модуле НастройкиСКД на НастройкиСКД = СКД.НастройкиПоУмолчанию; тогда НастройкиСКД.ДоступныеПоляДополнительныхОтборов выдаёт правильный список отборов,   но,  конечно с значениями по умолчанию....

Далее
Страница 5 из 10« Первая...34567...10...Последняя »

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.