Подключение дополнительного внешнего отчета СКД для управляемого приложения

1 отзывFavoriteLoadingВ закладки

Бороздя просторы Интернета, я наткнулся на упоминание о том, что можно внешний отчет (в том числе на СКД) прицепить к любому разделу интерфейса (любой подсистемы) в управляемом приложении. Но больше ничего про это узнать не удалось (также как не получилось самостоятельно разобраться).  Братья и сестры, если кто сталкивался с подобной проблемой или знает её решение, подскажите пожалуйста.  Отчет на СКД (тоесть есть только сама СКД, форм нет), приложение – управляемое.

Вот текст модуля объекта внешнего отчета:

Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить(“Подсистема.Имущество”);

    ПараметрыРегистрации.Вставить(“Вид”, “ДополнительныйОтчет”);
    ПараметрыРегистрации.Вставить(“Назначение”, МассивНазначений);
    ПараметрыРегистрации.Вставить(“Наименование”, “Отчет1”);
    ПараметрыРегистрации.Вставить(“Версия”, “1.0”);
    ПараметрыРегистрации.Вставить(“БезопасныйРежим”, Истина);
    ПараметрыРегистрации.Вставить(“Информация”, “”);
 
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, “Отчет1”, “СКДОтчет1″,”ОткрытиеФормы”);

    ПараметрыРегистрации.Вставить(“Команды”, ТаблицаКоманд);
 
    Возврат ПараметрыРегистрации;
 
КонецФункции

Функция ПолучитьТаблицуКоманд()
 
     Команды = Новый ТаблицаЗначений;
     Команды.Колонки.Добавить(“Представление”, Новый ОписаниеТипов(“Строка”));
     Команды.Колонки.Добавить(“Идентификатор”, Новый ОписаниеТипов(“Строка”));
     Команды.Колонки.Добавить(“Использование”, Новый ОписаниеТипов(“Строка”));
     Команды.Колонки.Добавить(“ПоказыватьОповещение”, Новый ОписаниеТипов(“Булево”));
     Команды.Колонки.Добавить(“Модификатор”, Новый ОписаниеТипов(“Строка”));
     Возврат Команды;
 
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = “”)
 
      НоваяКоманда = ТаблицаКоманд.Добавить();
      НоваяКоманда.Представление = Представление;
      НоваяКоманда.Идентификатор = Идентификатор;
      НоваяКоманда.Использование = Использование;
      НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
      НоваяКоманда.Модификатор = Модификатор;
 
КонецПроцедуры

Буду очень признателен, если кто-нибудь откликнется

 

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

Один комментарий

  1. Если отчет на СКД и вы не передаете туда программно никаких параметров, насколько я понял по приведенному коду, то назначение задавать не нужно. Просто потом, при регистрации отчета укажите разделы, в которых он будет доступен в “Дополнительные отчеты”

Оставить комментарий

RSSКомментарии в RSS

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.