Здравствуйте. Бьюсь над такой задачей: нужно в стандартный прайс УТ 11 добавить поле, где бы выводилась картинка номенклатуры. К сожалению, не хватает опыта понять, как это сделать. Создал форму отчёта, в модуле пишу запрос на выборку картинок:

 

Процедура ВыбратьКартинкуИзПрисоединенныхФайлов(Команда)

Запрос = Новый Запрос(
“ВЫБРАТЬ
|    НоменклатураПрисоединенныеФайлы.Ссылка
|ИЗ
|    Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы
|ГДЕ
|    НоменклатураПрисоединенныеФайлы.ПометкаУдаления = ЛОЖЬ
|    И НоменклатураПрисоединенныеФайлы.Зашифрован = ЛОЖЬ
|    И НоменклатураПрисоединенныеФайлы.ТипХраненияФайла = ЗНАЧЕНИЕ(Перечисление.ТипыХраненияФайлов.ВТомахНаДиске)”);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

УникИдентификатор = Выборка.Ссылка.УникальныйИдентификатор();
ДанныеФайла = ПрисоединенныеФайлы.ПолучитьДанныеФайла(Выборка.Ссылка, УникИдентификатор);
ПрисоединенныйФайл_Объект = Выборка.Ссылка.ПолучитьОбъект();

КонецЦикла;
КонецПроцедуры

 

Здравствуйте. Бьюсь над такой задачей: нужно в стандартный прайс УТ 11 добавить поле, где бы выводилась картинка номенклатуры. К сожалению, не хватает опыта понять, как это сделать. Создал форму отчёта, в модуле пишу запрос на выборку картинок:   Процедура ВыбратьКартинкуИзПрисоединенныхФайлов(Команда) Запрос = Новый Запрос( “ВЫБРАТЬ |    НоменклатураПрисоединенныеФайлы.Ссылка |ИЗ |    Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы |ГДЕ |    НоменклатураПрисоединенныеФайлы.ПометкаУдаления = ЛОЖЬ |    И НоменклатураПрисоединенныеФайлы.Зашифрован = ЛОЖЬ |    И НоменклатураПрисоединенныеФайлы.ТипХраненияФайла = ЗНАЧЕНИЕ(Перечисление.ТипыХраненияФайлов.ВТомахНаДиске)”); Выборка = Запрос.Выполнить().Выбрать(); Пока Выборка.Следующий() Цикл УникИдентификатор = Выборка.Ссылка.УникальныйИдентификатор(); ДанныеФайла = ПрисоединенныеФайлы.ПолучитьДанныеФайла(Выборка.Ссылка, УникИдентификатор); ПрисоединенныйФайл_Объект = Выборка.Ссылка.ПолучитьОбъект(); КонецЦикла; КонецПроцедуры  ...