Посты от Декабрь, 2012

Вывод картинки в отчёт “Прайс-лист” для УТ 11

Отзывов (2)FavoriteLoadingВ закладки

Здравствуйте. Бьюсь над такой задачей: нужно в стандартный прайс УТ 11 добавить поле, где бы выводилась картинка номенклатуры. К сожалению, не хватает опыта понять, как это сделать. Создал форму отчёта, в модуле пишу запрос на выборку картинок:

 

Процедура ВыбратьКартинкуИзПрисоединенныхФайлов(Команда)

Запрос = Новый Запрос(
“ВЫБРАТЬ
|    НоменклатураПрисоединенныеФайлы.Ссылка
|ИЗ
|    Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы
|ГДЕ
|    НоменклатураПрисоединенныеФайлы.ПометкаУдаления = ЛОЖЬ
|    И НоменклатураПрисоединенныеФайлы.Зашифрован = ЛОЖЬ
|    И НоменклатураПрисоединенныеФайлы.ТипХраненияФайла = ЗНАЧЕНИЕ(Перечисление.ТипыХраненияФайлов.ВТомахНаДиске)”);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

УникИдентификатор = Выборка.Ссылка.УникальныйИдентификатор();
ДанныеФайла = ПрисоединенныеФайлы.ПолучитьДанныеФайла(Выборка.Ссылка, УникИдентификатор);
ПрисоединенныйФайл_Объект = Выборка.Ссылка.ПолучитьОбъект();

КонецЦикла;
КонецПроцедуры

 

Здравствуйте. Бьюсь над такой задачей: нужно в стандартный прайс УТ 11 добавить поле, где бы выводилась картинка номенклатуры. К сожалению, не хватает опыта понять, как это сделать. Создал форму отчёта, в модуле пишу запрос на выборку картинок:   Процедура ВыбратьКартинкуИзПрисоединенныхФайлов(Команда) Запрос = Новый Запрос( “ВЫБРАТЬ |    НоменклатураПрисоединенныеФайлы.Ссылка |ИЗ |    Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы |ГДЕ |    НоменклатураПрисоединенныеФайлы.ПометкаУдаления = ЛОЖЬ |    И НоменклатураПрисоединенныеФайлы.Зашифрован = ЛОЖЬ |    И НоменклатураПрисоединенныеФайлы.ТипХраненияФайла = ЗНАЧЕНИЕ(Перечисление.ТипыХраненияФайлов.ВТомахНаДиске)”); Выборка = Запрос.Выполнить().Выбрать(); Пока Выборка.Следующий() Цикл УникИдентификатор = Выборка.Ссылка.УникальныйИдентификатор(); ДанныеФайла = ПрисоединенныеФайлы.ПолучитьДанныеФайла(Выборка.Ссылка, УникИдентификатор); ПрисоединенныйФайл_Объект = Выборка.Ссылка.ПолучитьОбъект(); КонецЦикла; КонецПроцедуры  ...

Далее

Вывод разных колонок ресурсов в зависимости от даты

Ваш отзывFavoriteLoadingВ закладки

Как в скд замутить, есть настройка грубо говоря таблица
строки – Номенклатура
Колонки – Дата
Можно сделать так чтобы на все даты выводится одна колонка ресурсов, а на определенные даты – 4 колонки ресурсов ( таблицу с данными формирую и передаю программано)
Тут грубо говоря итоги по декадам с хитрожопыми расчетами

Дата 1
ресурс1

Дата2
ресурс1

Декада
ресурс1
ресурс2
ресурс3
ресурс4

Как в скд замутить, есть настройка грубо говоря таблица строки – Номенклатура Колонки – Дата Можно сделать так чтобы на все даты выводится одна колонка ресурсов, а на определенные даты – 4 колонки ресурсов ( таблицу с данными формирую и передаю программано) Тут грубо говоря итоги по декадам с хитрожопыми расчетами Дата 1 ресурс1 Дата2 ресурс1 … Декада ресурс1 ресурс2 ресурс3 ресурс4 Перейти к...

Далее

Вроде простой запрос

Отзывов (3)FavoriteLoadingВ закладки

Помогите разобраться. Имеем запрос, в котором справочник связан с собственной табличной частью вложенным запросом:

 
ВЫБРАТЬ

Проекты.Ссылка КАК Монтаж,

Проекты.Приоритет КАК Приоритет,

ВложенныйЗапросГИС.ГИС КАК ГИС

ИЗ Справочник.Проекты КАК Проекты

ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ ПЕРВЫЕ 1

ПроектыСписокИТР.ФизЛицо КАК ГИС,

ПроектыСписокИТР.Ссылка КАК Монтаж1

ИЗ Справочник.Проекты.СписокИТР КАК ПроектыСписокИТР

ГДЕ ПроектыСписокИТР.Роль.Наименование = &ГИС
УПОРЯДОЧИТЬ ПО ГИС) КАК ВложенныйЗапросГИС

ПО Проекты.Ссылка = ВложенныйЗапросГИС.Монтаж1
УПОРЯДОЧИТЬ ПО

Приоритет, Монтаж

 
Из табличной части нужно получить одну запись определённого вида. Вид задаётся параметром &ГИС. Данный запрос не работает. Но путём изменения количества в предложении “ВЫБРАТЬ ПЕРВЫЕ 1” подзапроса, выяснилось, что запрос начинает работать при различных значениях. Какие-то записи выбираются при 3, какие-то при 14.
Пример:

Помогите разобраться. Имеем запрос, в котором справочник связан с собственной табличной частью вложенным запросом:   ВЫБРАТЬ Проекты.Ссылка КАК Монтаж, Проекты.Приоритет КАК Приоритет, ВложенныйЗапросГИС.ГИС КАК ГИС ИЗ Справочник.Проекты КАК Проекты ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ ПЕРВЫЕ 1 ПроектыСписокИТР.ФизЛицо КАК ГИС, ПроектыСписокИТР.Ссылка КАК Монтаж1 ИЗ Справочник.Проекты.СписокИТР КАК ПроектыСписокИТР ГДЕ ПроектыСписокИТР.Роль.Наименование = &ГИС УПОРЯДОЧИТЬ ПО ГИС) КАК ВложенныйЗапросГИС ПО Проекты.Ссылка = ВложенныйЗапросГИС.Монтаж1 УПОРЯДОЧИТЬ ПО Приоритет, Монтаж   Из табличной части нужно получить одну запись определённого вида. Вид задаётся параметром &ГИС. Данный запрос не работает. Но путём изменения количества в предложении “ВЫБРАТЬ ПЕРВЫЕ 1” подзапроса, выяснилось, что запрос начинает работать при различных значениях. Какие-то записи выбираются при 3, какие-то при 14. Пример:...

Далее

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.