Подскажите пожалуйста.Делаю отчет в СКД.Создала 2 варианта отчета.на форму вывела поле выбора варианта отчета,но почему то у меня не показываются варианты отчетов.

Отзывов (2)FavoriteLoadingВ закладки

Процедура ПриОткрытии()

    Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    Для каждого вариант из макет.ВариантыНастроек Цикл
        ЭлементыФормы.Варианты.СписокВыбора.Добавить(вариант.Представление);
    КонецЦикла;
    Варианты = ЭлементыФормы.Варианты.СписокВыбора[0].значение;

КонецПроцедуры

Процедура ВариантыПриИзменении(Элемент)
     Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    настройки=ОпределитьНастройки(макет, элемент.значение);
    КомпоновщикНастроек.ЗагрузитьНастройки(настройки);
    ЭлементыФормы.Результат.Очистить();
    СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки);

КонецПроцедуры
 Функция ОпределитьНастройки(Макет, представлениеМакета)
Для каждого вариант из макет.ВариантыНастроек Цикл
        если вариант.Представление=представлениеМакета тогда
            настройки=вариант.настройки;
        КонецЕсли;
    КонецЦикла;
Возврат настройки;
КонецФункции
google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

2 Коммент.

  1. Вы неверно формируете список макетов. Есть два способа:
    1. Ручной. Вы вручную составляете список макетов и заганяете его в поле списка
    2. Обойти все макеты отчета/обработки программно – с помощью Метаданные.Обработки..Макеты Или
    Метаданные.Отчеты..Макеты.

    Тгда в процедуре “ВариантыПриИзменении(Элемент)” будет следующее –
    Макет = ПолучитьМакет(Элемент.Значение);

  2. В данном случае вы формируете не список “вариантов отчета” (кстати немного не понял что это), список вариантов настроек – то есть, варианты настроек, которые находятся на вкладке “Настройки” вашей схемы компоновки данных с именем “ОсновнаяСхемаКомпоновкиДанных”.
    Если же вы этого и хотите, то все полностью работает, проверьте поле “Представление” возможно у вас многоязыковый интерфейс и вы не ввели имена для других языков. Отсюда и заполняются пустые строки.

Оставить комментарий

RSSКомментарии в RSS

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.