Процедура ПриОткрытии()

    Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    Для каждого вариант из макет.ВариантыНастроек Цикл
        ЭлементыФормы.Варианты.СписокВыбора.Добавить(вариант.Представление);
    КонецЦикла;
    Варианты = ЭлементыФормы.Варианты.СписокВыбора[0].значение;

КонецПроцедуры

Процедура ВариантыПриИзменении(Элемент)
     Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    настройки=ОпределитьНастройки(макет, элемент.значение);
    КомпоновщикНастроек.ЗагрузитьНастройки(настройки);
    ЭлементыФормы.Результат.Очистить();
    СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки);

КонецПроцедуры
 Функция ОпределитьНастройки(Макет, представлениеМакета)
Для каждого вариант из макет.ВариантыНастроек Цикл
        если вариант.Представление=представлениеМакета тогда
            настройки=вариант.настройки;
        КонецЕсли;
    КонецЦикла;
Возврат настройки;
КонецФункции
Процедура ПриОткрытии() Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); Для каждого вариант из макет.ВариантыНастроек Цикл ЭлементыФормы.Варианты.СписокВыбора.Добавить(вариант.Представление); КонецЦикла; Варианты = ЭлементыФормы.Варианты.СписокВыбора[0].значение; КонецПроцедуры Процедура ВариантыПриИзменении(Элемент) Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); настройки=ОпределитьНастройки(макет, элемент.значение); КомпоновщикНастроек.ЗагрузитьНастройки(настройки); ЭлементыФормы.Результат.Очистить(); СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки); КонецПроцедуры Функция ОпределитьНастройки(Макет, представлениеМакета) Для каждого вариант из макет.ВариантыНастроек Цикл если вариант.Представление=представлениеМакета тогда настройки=вариант.настройки; КонецЕсли; КонецЦикла; Возврат настройки; КонецФункции Перейти к...