Выбор из нескольких макетов.

Отзывов (2)FavoriteLoadingВ закладки

Здравствуйте.Подскажите пожалуйста,как решить задачку.Есть внешний отчет с несколькими макетами СКД.Пользователю нужно на форме отчета выбрать один из них и вывести.В какую сторону копать?

Заранее,спасибо.

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

2 Коммент.

  1. В реквизиты формы добавить реквизит:
    “СписокВариантов” Тип “Строка”

    Добавить на форму поле выбора:
    Имя: Варианты
    Данные: СписокВариантов
    События: ПриИзменении: “ВариантыПриИзменении”

    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

    //Заполнение вариантов отчета
    Макеты = ЭтотОбъект.Метаданные().Макеты;
    Для Каждого Схема ИЗ Макеты Цикл
    ВариантыОтчета.Добавить(Схема.Имя,Схема.Синоним);
    КонецЦикла;
    ЭлементыФормы.Варианты.СписокВыбора = ВариантыОтчета;
    СписокВариантов = ЭлементыФормы.Варианты.СписокВыбора[0].Значение;

    КонецПроцедуры // ПередОткрытием()

    Процедура ВариантыПриИзменении(Элемент)
    СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет(Элемент.Значение);
    Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
    КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
    КонецПроцедуры

    Должно сработать.
    У меня работает. :)

  2. Спасибо большое,буду пробовать.Хотя,конечно,решил другим способом.Запрос,вывод результата в ТабДок и т.п.
    Но интересен все же Ваш вариант.)

Оставить комментарий

RSSКомментарии в RSS

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.