Вывожу в ТД отчёт, всё хорошо, все данные вывелись, но почему пустые строки после шапки и перед итогом, макет рисовал сам, области выделены верно???

 

Пример:

В СКД нарисовал макет (рис 1) и привязал его к данным (рис 2), результат (рис 3).

Код вывода:

&НаКлиенте
Процедура Сформировать(Команда)
	СКД = Отчеты.ВедомостьЗамераОстатков.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");	
	Настройки = СКД.НастройкиПоУмолчанию;	
	Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных;
	
	МакетКомпоновки = Новый КомпоновщикМакетаКомпоновкиДанных;
	Макет = МакетКомпоновки.Выполнить(СКД,Настройки,Расшифровка);
	
	ПроцессорКомпоновки = новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(Макет);
	
	ПроцессорВывода = новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	
	ТД.Очистить();
	ТД.АвтоМасштаб = Истина;
	ТД.НижнийКолонтитул.Выводить = Истина;
	ТД.НижнийКолонтитул.ТекстСправа = "Страница [&НомерСтраницы] из [&СтраницВсего]";
	
	ПроцессорВывода.УстановитьДокумент(ТД);
	
	ПроцессорВывода.НачатьВывод();
	
	Пока Истина Цикл
    	ЭлементРезультата = ПроцессорКомпоновки.Следующий();
    	Если ЭлементРезультата= Неопределено Тогда
        	Прервать;
		Иначе						
        	ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);			
        КонецЕсли;
    КонецЦикла;
  
	ПроцессорВывода.ЗакончитьВывод();
	
КонецПроцедуры

 

Вывожу в ТД отчёт, всё хорошо, все данные вывелись, но почему пустые строки после шапки и перед итогом, макет рисовал сам, области выделены верно???   Пример: В СКД нарисовал макет (рис 1) и привязал его к данным (рис 2), результат (рис 3). Код вывода: &НаКлиенте Процедура Сформировать(Команда) СКД = Отчеты.ВедомостьЗамераОстатков.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"); Настройки = СКД.НастройкиПоУмолчанию; Расшифровка = Новый ДанныеРасшифровкиКомпоновкиДанных; МакетКомпоновки = Новый КомпоновщикМакетаКомпоновкиДанных; Макет = МакетКомпоновки.Выполнить(СКД,Настройки,Расшифровка); ПроцессорКомпоновки = новый ПроцессорКомпоновкиДанных; ПроцессорКомпоновки.Инициализировать(Макет); ПроцессорВывода = новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент; ТД.Очистить(); ТД.АвтоМасштаб = Истина; ТД.НижнийКолонтитул.Выводить = Истина; ТД.НижнийКолонтитул.ТекстСправа = "Страница [&НомерСтраницы] из [&СтраницВсего]"; ПроцессорВывода.УстановитьДокумент(ТД); ПроцессорВывода.НачатьВывод(); Пока Истина Цикл ЭлементРезультата = ПроцессорКомпоновки.Следующий(); Если ЭлементРезультата= Неопределено Тогда Прервать; Иначе ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата); КонецЕсли; КонецЦикла; ПроцессорВывода.ЗакончитьВывод(); КонецПроцедуры  ...