Как добавить отбор программно

Отзывов (4)FavoriteLoadingВ закладки

НовыйЭлементОтбора = КомпоновщикНастроек.Настройки.Отбор.Элементы.
                     Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));

ПолеОтбора = Новый ПолеКомпоновкиДанных("ИмяПоляКомпоновки");

НовыйЭлементОтбора.ЛевоеЗначение  = ПолеОтбора;
НовыйЭлементОтбора.Использование  = Истина;
НовыйЭлементОтбора.ВидСравнения   = ВидСравненияКомпоновкиДанных.Равно;
НовыйЭлементОтбора.ПравоеЗначение = Значение;

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

4 Коммент.

  1. Здравствуйте! Не могу найти ответа на такой вопрос. Везде вот примеры по отборам только основным. А как быть с отбором по группировке. У меня вот такая проблемма: в настройках СКД добавлены отборы по группировкам, при выборе определенных значений реквизитов на форме отчета нужно сделать так, чтобы отборы включались или отключались. Для основного отбора всё понятно как это сделать КомпоновщикНастроек.Настройки.Отбор.Элементы[индекс], но в этот массив элементов не попадают отборы по группировкам. Как программно добраться до галочки “Использовать” у отбора группировки ?

    • ЭлементОтбора = ПолучитьЭлементОтбора(“ИмяПредставлениеОтбора”);
      ЭлементОтбора.Использование = Ложь;
      //___________________________________________________________
      Функция ПолучитьЭлементОтбора(ПредставлениеОтбора)
      Для каждого ЭлементОтбора Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
      Если ЭлементОтбора.Представление = ПредставлениеОтбора Тогда
      Возврат ЭлементОтбора;
      КонецЕсли;
      КонецЦикла;
      Возврат “”;
      КонецФункции

Трекбеки/Пинги

  1. payday loans - payday loans... Subscribed to your weblog, many thanks...

Оставить комментарий

RSSКомментарии в RSS

Авторизация

Логин:
Пароль:
Регистрация

Архивы

Закладки

  • Your favorites will be here.